Bug 94996 - [vulkan, SKL] deqp-vk.spirv_assembly.instruction.graphics.opquantize regression
Summary: [vulkan, SKL] deqp-vk.spirv_assembly.instruction.graphics.opquantize regression
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-18 19:03 UTC by Mark Janes
Modified: 2016-05-17 17:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-04-18 19:03:20 UTC
With the merge of vulkan into mesa master, the following set of tests began failing on skylake with "Fail (Upper right corner mismatch)"

deqp-vk.spirv_assembly.instruction.graphics.opquantize.carry_bit_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.carry_to_exponent_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.inf_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.negative_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.negative_inf_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.negative_round_up_or_round_down_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.positive_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.positive_round_up_or_round_down_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.round_to_inf_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.round_to_negative_inf_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.spec_const_carry_bit_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.spec_const_carry_to_exponent_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.spec_const_negative_round_up_or_round_down_geom
deqp-vk.spirv_assembly.instruction.graphics.opquantize.spec_const_positive_round_up_or_round_down_geom
Comment 1 Mark Janes 2016-04-18 23:47:05 UTC
opquantize tests are disabled in CI, due to some intermittent behavior for these tests.  They should be re-enabled when the bug is fixed.
Comment 2 Jason Ekstrand 2016-05-17 17:23:27 UTC
This should be fixed since switching to scalar geometry shaders by default.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.