Bug 9506 - r300 crash on Misfit Model 3D
Summary: r300 crash on Misfit Model 3D
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-01 10:15 UTC by Jacek Poplawski
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg configuration (2.12 KB, text/plain)
2007-01-03 10:51 UTC, Jacek Poplawski
no flags Details
xorg log (56.66 KB, text/plain)
2007-01-03 10:52 UTC, Jacek Poplawski
no flags Details
Xorg log, no crash (56.46 KB, text/plain)
2007-01-09 07:53 UTC, Jonathan Bastien-Filiatrault
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacek Poplawski 2007-01-01 10:15:49 UTC
I was just testing new application and for the first time crash happened here on
Mesa 6.5.2.

I can reproduce this each time:
1) start Misfit Model 3D (http://www.misfitcode.com/misfitmodel3d/)
2) create torus (click on torus icon and draw it in any view)
3) rotate it - system will crash

My system:
- Linux version 2.6.19-ARCH
- mesa 6.5.2-1
- xf86-video-ati 6.6.3-3
- Mesa DRI R300 20060815 AGP 4x x86/MMX+/3DNow!+/SSE2 TCL
- ATI Radeon 9800PRO NH (AGP)
Comment 1 Jerome Glisse 2007-01-02 04:37:33 UTC
Could you run, from a console and attach output of the software.
You don't have lockup right ?
Comment 2 Jacek Poplawski 2007-01-02 05:18:48 UTC
I have total lockup every time.
Comment 3 Jerome Glisse 2007-01-02 05:40:40 UTC
Please attach your xorg log and conf.
Comment 4 Jacek Poplawski 2007-01-03 10:51:46 UTC
Created attachment 8284 [details]
xorg configuration
Comment 5 Jacek Poplawski 2007-01-03 10:52:51 UTC
Created attachment 8285 [details]
xorg log
Comment 6 Jacek Poplawski 2007-01-03 10:53:50 UTC
All other applications works without lockup, don't you have lockup when you run
misfit on your Radeon?
Comment 7 Jonathan Bastien-Filiatrault 2007-01-09 07:53:02 UTC
Created attachment 8343 [details]
Xorg log, no crash
Comment 8 Jonathan Bastien-Filiatrault 2007-01-09 07:56:36 UTC
I do not have these lockups anymore, I am not able to reproduce the bug with
Misfit 1.2.1. I am running mostly on Debian etch.

ati_drv.so: 6.6.3
radeon_drv.so: 4.2.0
OpenGL renderer string: Mesa DRI R300 20060815 AGP 4x TCL
OpenGL version string: 1.3 Mesa 6.5.1
HW: ATI Radeon 9800PRO NH (AGP)
Comment 9 Jonathan Bastien-Filiatrault 2007-01-09 07:58:51 UTC
Additional info:

Debian kernel 2.6.18-3-k7
libGL: XF86DRIGetClientDriverName: 5.2.0 r300 (screen 0)
Comment 10 Jerome Glisse 2007-01-09 08:00:25 UTC
Jacek which version of misfitmodel are you using ?
Comment 11 Jacek Poplawski 2007-01-09 08:05:58 UTC
The same, 1.2.1, but please notice that I use Mesa 6.5.2, not 6.5.1 as Jonathan,
maybe that's the reason. 

Could you try it with Mesa 6.5.2?
Comment 12 Jonathan Bastien-Filiatrault 2007-01-09 10:08:49 UTC
I'm having trouble building Mesa, I am using the 6.5.2 source off their website.
I have tried building with the debian patches for 6.5.1 (whole) and the debian
patches (only 'configs' and 'debian' directories). Both builds terminate the
same way:
../../../bin/mklib -o GL -linker 'cc' \
                -major 1 -minor 2  \
                -install ../../../lib `pkg-config --libs x11 xext xxf86vm` -lm
-lpthread -ldl `pkg-config --libs libdrm` glcontextmodes.o clientattrib.o
compsize.o eval.o glxcmds.o glxext.o glxextensions.o indirect.o indirect_init.o
indirect_size.o indirect_window_pos.o indirect_transpose_matrix.o
indirect_vertex_array.o indirect_vertex_program.o pixel.o pixelstore.o render2.o
renderpix.o single2.o singlepix.o vertarr.o xfont.o glx_pbuffer.o glx_query.o
glx_texture_compression.o dri_glx.o XF86dri.o ../../../src/mesa/main/dispatch.o
../../../src/mesa/glapi/glapi.o ../../../src/mesa/glapi/glthread.o
mklib: Making Linux shared library:  libGL.so.1.2
../../../src/mesa/main/dispatch.o: In function `gl_dispatch_stub_366':
dispatch.c:(.text+0xc910): multiple definition of `gl_dispatch_stub_366'
indirect.o:indirect.c:(.text+0xf860): first defined here
/usr/bin/ld: Warning: size of symbol `gl_dispatch_stub_366' changed from 236 in
indirect.o to 71 in ../../../src/mesa/main/dispatch.o
../../../src/mesa/main/dispatch.o: In function `gl_dispatch_stub_365':
dispatch.c:(.text+0xc9b0): multiple definition of `gl_dispatch_stub_365'
indirect.o:indirect.c:(.text+0xf9e0): first defined here
/usr/bin/ld: Warning: size of symbol `gl_dispatch_stub_365' changed from 236 in
indirect.o to 71 in ../../../src/mesa/main/dispatch.o
../../../src/mesa/main/dispatch.o: In function `gl_dispatch_stub_364':
dispatch.c:(.text+0xca50): multiple definition of `gl_dispatch_stub_364'
indirect.o:indirect.c:(.text+0x116d0): first defined here
/usr/bin/ld: Warning: size of symbol `gl_dispatch_stub_364' changed from 348 in
indirect.o to 93 in ../../../src/mesa/main/dispatch.o

If someone has any pointers, it would be appreciated.
Comment 13 Jonathan Bastien-Filiatrault 2007-01-09 10:39:43 UTC
Looking at
http://packages.debian.org/changelogs/pool/main/m/mesa/mesa_6.5.1-0.4/changelog#versionversion6.5.1-0.2
, it seems this could be an optimization problem, Debian seems to fore go some
optimizations to provide better stabiliy, Jacek's library seems to have the
optimizations while mine does not. Meanwhile i'll keep googling to try to build
mesa. 
Comment 14 Jacek Poplawski 2007-01-09 10:55:47 UTC
package I use is build with these options:

http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/x11-drivers/xf86-video-ati/PKGBUILD?rev=1.11&cvsroot=Current&only_with_tag=CURRENT&content-type=text/vnd.viewcvs-markup

I asked to remove OPTFLAGS from build, because with OPTFLAGS Blender fix in Mesa
didn't work.
Comment 15 chemtech 2013-03-15 14:27:02 UTC
Jacek Poplawski 
Do you still experience this issue with newer soft ?
Please check the status of your issue.
Comment 16 Martin Peres 2019-10-14 13:20:13 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.