Bug 95107 - PackageKit can fill hard drive with package cache
Summary: PackageKit can fill hard drive with package cache
Status: RESOLVED DUPLICATE of bug 80053
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-24 17:15 UTC by Milan Bouchet-Valat
Modified: 2018-01-29 12:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
ls -l for updates-testing repo (220.55 KB, text/plain)
2016-04-24 17:15 UTC, Milan Bouchet-Valat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2016-04-24 17:15:11 UTC
Created attachment 123213 [details]
ls -l for updates-testing repo

Today several applications crashed while I was working, and it turned out this was due to / having 0 free space. Over time, PackageKit had created a package cache of about 10GB at /var/cache/PackageKit, mostly under /var/cache/PackageKit/metadata/updates/packages/ and /var/cache/PackageKit/metadata/updates-testing/packages/.

I'm using Fedora 23, and I haven't applied updates for about one month. But the cache contains packages with older versions than the ones I have installed. For example, I'm using xorg-x11-server-common-1.18.2-1, but the cache contains both versions 1.18.1-3 and 1.18.3-1 (see attached list for updates repo -- unfortunately, I've removed updates-testing packages before listing files). The cache even contains Fedora 22 packages from December (when I upgraded).


There seem to be two bugs here:
- Old packages should be removed when a newer version is installed
- The cache shouldn't grow without limit. In particular, downloads should stop when / is low on free space. I ended up in a situation where I couldn't even apply the updates due to lack of free space!
Comment 1 Carwyn Edwards 2018-01-29 12:55:59 UTC
Duplicate of bug #80053
Comment 2 Carwyn Edwards 2018-01-29 12:56:37 UTC

*** This bug has been marked as a duplicate of bug 80053 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.