Bug 95132 - Regression: Mouse cursor disappears after returning from suspend to RAM
Summary: Regression: Mouse cursor disappears after returning from suspend to RAM
Status: RESOLVED DUPLICATE of bug 94677
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-25 14:13 UTC by nicolasmaia
Modified: 2016-04-27 14:03 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicolasmaia 2016-04-25 14:13:50 UTC
When I close my laptop lid and reopen, I'm faced with my login greeter (lightdm-webkit2-greeter) and the mouse cursor appears just fine. When I enter the credentials and initiate the actual session (i.e., get to the desktop), the mouse cursor becomes invisible.

I can still hover over things and click on them, but the cursor is invisible. In my case I can only get my cursor visible again when I reboot the system (or hibernate and come back from it).

This is a clear regression since I upgraded to GNOME 3.20 from the latest version prior to that. I'm not clear what the number of the version was, but I'm positive it was the latest, since I update my computer on a daily basis.

According to other reports, downgrading to xorg-server-1.18.1-3-x86_64 solves this issue, and updating it to the current version (xorg-server-1.18.2-4-x86_64) causes the bug to reappear, although I can't confirm it. Source: https://bugs.archlinux.org/task/48713

Related links:

https://github.com/Antergos/lightdm-webkit2-greeter/issues/40
https://bugzilla.gnome.org/show_bug.cgi?id=764994
Comment 1 Michel Dänzer 2016-04-27 10:02:51 UTC
Assuming you're using the intel driver, this is a duplicate of bug 94677.
Comment 2 nicolasmaia 2016-04-27 10:32:12 UTC
You're probably right, as I use the Intel driver.
Comment 3 Michel Dänzer 2016-04-27 14:03:47 UTC

*** This bug has been marked as a duplicate of bug 94677 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.