Bug 95242 - piglit.spec.arb_separate_shader_objects.execution.layout-location-named-block regression
Summary: piglit.spec.arb_separate_shader_objects.execution.layout-location-named-block...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Timothy Arceri
QA Contact: Intel 3D Bugs Mailing List
URL: https://cvs.khronos.org/bugzilla/show...
Whiteboard:
Keywords:
: 95431 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-02 18:38 UTC by Mark Janes
Modified: 2019-01-08 00:34 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-05-02 18:38:29 UTC
mesa 0d88b15f073d09afed1747d9cdde98f15c7aa28d regressed this test:

Standard Output

/tmp/build_root/m64/lib/piglit/bin/shader_runner /tmp/build_root/m64/lib/piglit/tests/spec/arb_separate_shader_objects/execution/layout-location-named-block.shader_test -auto
piglit: debug: Requested an OpenGL 3.2 Core Context, and received a matching 3.3 context

Standard Error

Failed to link:
error: fragment shader input `name2' with explicit location has no matching output
error: fragment shader input `name' with explicit location has no matching output

------------------------------------------------------------
Author:     Timothy Arceri <timothy.arceri@collabora.com>
glsl: cross validate varyings with a component qualifier

This change checks for component overlap, including handling overlap of
locations and components by doubles. Previously there was no validation
for assigning explicit locations to a location used by the second half
of a double.

V3: simplify handling of doubles and fix double component aliasing
detection

V2: fix component matching for matricies

Reviewed-by: Anuj Phogat <anuj.phogat@gmail.com>
Reviewed-by: Edward O'Callaghan <eocallaghan@alterapraxis.com>
Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Comment 1 Timothy Arceri 2016-05-17 01:55:36 UTC
*** Bug 95431 has been marked as a duplicate of this bug. ***
Comment 2 Timothy Arceri 2016-05-17 02:00:35 UTC
I wrote this piglit test then later noticed that it may not be legal although it works on both the Nvidia and AMD binary drivers.

I filled a bug with Khronos https://cvs.khronos.org/bugzilla/show_bug.cgi?id=15338 I keep forgetting to remind Ian about it before the meetings.
Comment 3 Timothy Arceri 2019-01-08 00:34:23 UTC
This was fixed long ago. Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.