Bug 95298 - Can't "connect" to external display attached to docking station via DP on laptop with Intel/AMD dual
Summary: Can't "connect" to external display attached to docking station via DP on lap...
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2016-05-06 14:41 UTC by Yaroslav Halchenko
Modified: 2019-11-19 09:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

entire dmesg from the boot #1 (567.58 KB, text/plain)
2016-05-06 14:41 UTC, Yaroslav Halchenko
no flags Details

Description Yaroslav Halchenko 2016-05-06 14:41:26 UTC
Created attachment 123520 [details]
entire dmesg from the boot #1

I have HP zbook 14 and using Debian testing/unstable.  External monitor is connected to docking station serving two DP connections.  To make those visible to xrandr I do

xrandr --setprovideroffloadsink 1 0
xrandr --setprovideroutputsource 1 0

where 0 corresponds to Intel, 1 to Radeon/OLAND (name changed when upgraded).
Setup was working with stock debian packages (kernel was 4.4.2-3) for awhile but there was an issue that display didn't refresh correctly and often I had blank patches and had to go to gnome overview and back to re-render.  So I have decided to upgrade to a current state of testing + some unstable.  Currently have xserver-xorg-core 2:1.18.3-1  xserver-xorg-video-ati 1:7.7.0-1  and kernel 4.5.1-1 .  Unfortunately I can't "turn on" the external display connected to the docking station -- screen blinks and comes back to display on the laptop, xrandr reports xrandr: Configure crtc 4 failed   and agd5f on IRC looking at http://www.onerussian.com/tmp/dmesg-20160506-1.txt (attached to this report as well) summarized as "link training failed on the display"
Comment 1 Alex Deucher 2016-05-06 14:44:02 UTC
Does appending radeon.runpm=0 on the kernel command line in grub help?
Comment 2 Alex Deucher 2016-05-06 14:44:36 UTC
Did the monitor light up previously on a different kernel?  If so which one?  Can you bisect?
Comment 3 Yaroslav Halchenko 2016-05-06 15:11:45 UTC
prev kernel: 4.4.2-3  -- yes it connected/light up no problem.  I had 1 more issue though (may be relevant).  When I come to work, and drop laptop into docking station, if then external monitor immediately lights up in 'clone' mode, I had to turn it off in xrandr/Displays, since otherwise whenever I run my stock "enable external monitor, disable laptop" xrandr line the whole display would go black without any signs of life from the laptop and I had to reboot.  I have forgot if/where I had report on that issue.  If I turned it off first in Gnome Display and then run xrandr to enable external in Primary mode -- it worked fine.

runpm: I will try whenever free time emerges (later today/or monday)

bisection: if only nothing left for poor me.  This is the main workhorse machine for me
Comment 4 Martin Peres 2019-11-19 09:16:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/718.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.