Bug 96318 - drm/i915 crash on 4.6.0
Summary: drm/i915 crash on 4.6.0
Status: CLOSED DUPLICATE of bug 95108
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-01 23:26 UTC by kuduk
Modified: 2016-06-02 07:59 UTC (History)
2 users (show)

See Also:
i915 platform: SKL
i915 features: GPU hang


Attachments
crash dump (464.86 KB, text/plain)
2016-06-01 23:26 UTC, kuduk
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description kuduk 2016-06-01 23:26:01 UTC
Created attachment 124250 [details]
crash dump

GPU is hanging, attached there's the crash dump.

Seems related to issues with RC6 on 4.5.0 as well.

kuduk@xps13:~$ uname -a
Linux xps13 4.6.0-trunk-amd64 #1 SMP Debian 4.6-1~exp1 (2016-05-17) x86_64 GNU/Linux

kuduk@xps13:~$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 0a)

kuduk@xps13:~$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.6.0-trunk-amd64 root=/dev/mapper/xps13--vg-root ro quiet


[25990.213735] [drm] stuck on render ring
[25990.214214] [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1861], reason: Ring hung, action: reset
[25990.214216] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[25990.214216] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[25990.214217] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[25990.214217] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[25990.214218] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[25990.216368] drm/i915: Resetting chip after gpu hang
[25991.221768] [drm] RC6 on
[25998.226092] [drm] stuck on render ring
[25998.226480] [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1861], reason: Ring hung, action: reset
[25998.226635] [drm:i915_set_reset_status [i915]] *ERROR* gpu hanging too fast, banning!
[25998.228760] drm/i915: Resetting chip after gpu hang
[25999.234649] [drm] RC6 on
Comment 1 yann 2016-06-02 07:45:26 UTC
For both bugs:
- Hung happening on "render" ring, 
- Application is "Xorg",
- HW/PCI_ID is "0x1926",
- Instruction/IPETH is "0x7a000004"

*** This bug has been marked as a duplicate of bug 94021 ***
Comment 2 yann 2016-06-02 07:46:45 UTC
mistaken on duplicated bug, fixing it

*** This bug has been marked as a duplicate of bug 95108 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.