Bug 96381 - Texture artifacts with immutable texture storage and mipmaps
Summary: Texture artifacts with immutable texture storage and mipmaps
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 11.2
Hardware: Other Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-04 23:40 UTC by Fabian Maurer
Modified: 2016-10-18 00:56 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot showing the artifacts (2.44 MB, image/png)
2016-06-04 23:40 UTC, Fabian Maurer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Maurer 2016-06-04 23:40:51 UTC
Created attachment 124320 [details]
Screenshot showing the artifacts

Playing a game on wine (NekoPara on steam), and got texture artifacts. I don't really know what causes it since I can't reproduce it on my own, but I created an apitrace to help with testing.

Some things I found out, artifacts disappear when:

1) LIBGL_ALWAYS_SOFTWARE=1 is set, or
2) glTexStorage2D is forced use no mipmaps, or
3) glTexImage2D is used instead of glTexStorage2D

Tested on OpenSuse Tumbleweed 64bit with latest mesa (11.2 and git 12.0), with amdgpu and a Radeon R9 285.
Issue is not present when tested on another system, apitrace works on another PC.

Screenshot attached.
Apitrace: http://www.mediafire.com/download/tk5z5r9ag0898qf/wine-preloader_NekoPara0.7z
(35MB, 197MB unpacked)
Comment 1 Ilia Mirkin 2016-06-05 00:09:26 UTC
Renders fine on nvc0 and nv50, both 11.2 and master. Sounds like a radeonsi issue, not mesa core.
Comment 2 Bas Nieuwenhuizen 2016-06-05 00:31:18 UTC
apitrace is has corruption without parameters and is correct with R600_DEBUG=nodcc on a R9 285 here, so definitely seems like a radeonsi issue.
Comment 3 Marek Olšák 2016-10-17 21:46:58 UTC
This seems to fixed. The output here looks the same on Tonga, Bonaire, and llvmpipe.
Comment 4 Fabian Maurer 2016-10-18 00:56:13 UTC
Can confirm that the issue isn't present anymore with a recent version of mesa.


bug/show.html.tmpl processed on Feb 28, 2017 at 05:27:56.
(provided by the Example extension).