Bug 96389 - Dota2 doesn't work with Vulkan on gen7-7.5
Summary: Dota2 doesn't work with Vulkan on gen7-7.5
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/intel (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-05 15:01 UTC by david becerra
Modified: 2019-09-05 08:47 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
vkcube -n cube.png result (4.77 KB, image/png)
2016-06-05 15:01 UTC, david becerra
Details
dota 2 vulkan after loading (49.34 KB, image/png)
2016-06-05 15:02 UTC, david becerra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description david becerra 2016-06-05 15:01:20 UTC
Created attachment 124330 [details]
vkcube -n cube.png result

im on manjaro linux and since the merge of anv branch with master mesa any vulkan aplicarion shows no image, im on hd 5500 and the issue happens with prebuillt or self built packages
Comment 1 david becerra 2016-06-05 15:02:25 UTC
Created attachment 124331 [details]
dota 2 vulkan after loading
Comment 2 Jason Ekstrand 2016-06-06 14:55:16 UTC
I think the heading is invalid.  Lots of stuff works, just not vkcube or dota2.  The problem with vkcube, frankly, is that it's a bad demo.  The bigger issue is with dota2.  I'm working on getting that fixed.
Comment 3 david becerra 2016-06-06 17:20:46 UTC
(In reply to Jason Ekstrand from comment #2)
> I think the heading is invalid.  Lots of stuff works, just not vkcube or
> dota2.  The problem with vkcube, frankly, is that it's a bad demo.  The
> bigger issue is with dota2.  I'm working on getting that fixed.

i said any application because the vulkan demos also failed 
(thats already reported) 

and like the original report says it worked just before the merge with master

thanks for quick reply and for working on this :-)
Comment 4 Jason Ekstrand 2016-06-06 18:02:19 UTC
(In reply to david becerra from comment #3)
> i said any application because the vulkan demos also failed 
> (thats already reported) 

What all demos have you tried?

As I said above, vkcube is kind-of terrible and has been broken for a while but that's a problem with vkcube.
Comment 5 david becerra 2016-06-06 18:53:25 UTC
(In reply to Jason Ekstrand from comment #4)
> (In reply to david becerra from comment #3)
> > i said any application because the vulkan demos also failed 
> > (thats already reported) 
> 
> What all demos have you tried?
> 
> As I said above, vkcube is kind-of terrible and has been broken for a while
> but that's a problem with vkcube.

https://github.com/SaschaWillems/Vulkan

EDIT: now they are working!
Comment 6 Jason Ekstrand 2016-06-10 17:04:08 UTC
Dota2 should now be working with master.
Comment 7 david becerra 2016-06-12 14:08:03 UTC
confirmed its working, thanks
Comment 8 Vedran Rodic 2016-06-15 07:27:24 UTC
But it's not supposed to be working on Ivy Bridge, right?
Comment 9 Vedran Rodic 2016-06-15 08:30:51 UTC
On my Haswell it also crashes quickly after showing the main menu. Mesa/Vulkan version 6ef50ef
Comment 10 Syntist 2016-06-15 08:41:01 UTC
Also Not working on Ivy Bridge, Mesa/Vulkan Version 6ef50ef. Demo also aren't working. When i run dota after loading it crashes immediately. 

When running demo Vulkanscene
syntist@Syntist-PC:~/Downloads/Vulkan-master/build/bin$ ./vulkanscene 
WARNING: Ivy Bridge Vulkan support is incomplete
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
vulkanscene: /home/syntist/Downloads/Vulkan-master/base/vulkantools.cpp:300: VkShaderModule_T* vkTools::loadShader(const char*, VkDevice, VkShaderStageFlagBits): Assertion `fp' failed.
Aborted (core dumped)
Comment 11 Syntist 2016-06-15 08:41:20 UTC
Also Not working on Ivy Bridge, Mesa/Vulkan Version 6ef50ef. Demo also aren't working. When i run dota after loading it crashes immediately. 

When running demo Vulkanscene
syntist@Syntist-PC:~/Downloads/Vulkan-master/build/bin$ ./vulkanscene 
WARNING: Ivy Bridge Vulkan support is incomplete
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
../../../../../src/intel/vulkan/gen7_pipeline.c:212: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
vulkanscene: /home/syntist/Downloads/Vulkan-master/base/vulkantools.cpp:300: VkShaderModule_T* vkTools::loadShader(const char*, VkDevice, VkShaderStageFlagBits): Assertion `fp' failed.
Aborted (core dumped)
Comment 12 david becerra 2016-06-15 11:24:46 UTC
try disabling steam overlay
if it doesn't work its because anv doesn't work very well on ivy bridge and haswell (for now)
Comment 13 Vedran Rodic 2016-06-15 15:59:52 UTC
It seems to work but is unstable (just crashed while alt-tabbing borderless window to non compositing LXDE) on Haswell with Steam overlay disabled.

On Ivy Bridge it just hangs after initial loading screen (all black window with cursor, and I'm able to alt-tab).
Comment 14 Edinson E. Padrón Urdaneta 2016-07-26 12:49:00 UTC
The game doesn't work for me either. Next is the relevant information:

## Error message

    CreateSwapChain():

    The selected graphics queue does not support presenting a swapchain image.

## Dump

    Installing breakpad exception handler for appid(steam)/version(1468023329)
    roaming config store loaded successfully - 1121 bytes.
    migrating temporary roaming config store
    Installing breakpad exception handler for appid(steam)/version(1468023329)
    Failed to init SteamVR because it isn't installed
    sh: lspci: command not found
    ExecCommandLine: ""/home/nodxine/.local/share/Steam/ubuntu12_32/steam" "steam://rungameid/570" "-vulkan" "
    ExecSteamURL: "steam://rungameid/570"
    Installing breakpad exception handler for appid(steam)/version(1468023329)
    System startup time: 21.23 seconds
    /home/nodxine/.steam/root/steam.sh: line 140: ID: unbound variable
    /home/nodxine/.steam/root/steam.sh: line 154: VERSION_ID: unbound variable
    /home/nodxine/.steam/root/steam.sh: line 140: ID: unbound variable
    /home/nodxine/.steam/root/steam.sh: line 154: VERSION_ID: unbound variable
    Running Steam on   64-bit
    STEAM_RUNTIME has been set by the user to: /home/nodxine/.local/share/Steam/ubuntu12_32/steam-runtime
    ExecCommandLine: "/home/nodxine/.local/share/Steam/ubuntu12_32/steam steam://open/driverhelperready"
    ExecSteamURL: "steam://open/driverhelperready"
    Generating new string page texture 71: 128x256, total string texture memory is 442.37 KB
    Game update: AppID 570 "Dota 2", ProcID 4670, IP 0.0.0.0:0
    ERROR: ld.so: object '/home/nodxine/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/home/nodxine/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    pid 4672 != 4671, skipping destruction (fork without exec?)
    ERROR: ld.so: object '/home/nodxine/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/home/nodxine/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    Using breakpad crash handler
    Setting breakpad minidump AppID = 570
    Forcing breakpad minidump interfaces to load
    Looking up breakpad interfaces from steamclient
    Calling BreakpadMiniDumpSystemInit
    Looking up breakpad interfaces from steamclient
    Calling BreakpadMiniDumpSystemInit
    Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198132301329 [API loaded yes]
    Steam_SetMinidumpSteamID:  Setting Steam ID:  76561198132301329
    Setting breakpad minidump AppID = 373300
    WARNING: Ivy Bridge Vulkan support is incomplete
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    /var/tmp/portage/media-libs/mesa-12.0.1/work/mesa-12.0.1/src/intel/vulkan/gen7_pipeline.c:213: FINISHME: VK_STRUCTURE_TYPE_PIPELINE_MULTISAMPLE_STATE_CREATE_INFO
    vulkan: No DRI3 support
    The selected graphics queue does not support presenting a swapchain image.
    vulkan/renderdevicevulkan.cpp 1041 CreateSwapChain():
    The selected graphics queue does not support presenting a swapchain image.

    ERROR: ld.so: object '/home/nodxine/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/home/nodxine/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/home/nodxine/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
    crash_20160726003729_1.dmp[4900]: Uploading dump (out-of-process)
    /tmp/dumps/crash_20160726003729_1.dmp
    /home/nodxine/.local/share/Steam/steamapps/common/dota 2 beta/game/dota.sh: line 104:  4674 Segmentation fault      ${STEAM_RUNTIME_PREFIX} ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
    Game removed: AppID 570 "Dota 2", ProcID 4674 
    No cached sticky mapping in ActivateActionSet.crash_20160726003729_1.dmp[4900]: Finished uploading minidump (out-of-process): success = yes
    crash_20160726003729_1.dmp[4900]: response: Discarded=1
    crash_20160726003729_1.dmp[4900]: file ''/tmp/dumps/crash_20160726003729_1.dmp'', upload yes: ''Discarded=1''
    pid 4900 != 4899, skipping destruction (fork without exec?)

## glxinfo

    name of display: :0.0
    display: :0  screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.4
    server glx extensions:
        GLX_ARB_create_context, GLX_ARB_create_context_profile, 
        GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float, 
        GLX_ARB_framebuffer_sRGB, GLX_ARB_multisample, 
        GLX_EXT_create_context_es2_profile, GLX_EXT_framebuffer_sRGB, 
        GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
        GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
        GLX_OML_swap_method, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
        GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, GLX_SGI_swap_control
    client glx vendor string: Mesa Project and SGI
    client glx version string: 1.4
    client glx extensions:
        GLX_ARB_create_context, GLX_ARB_create_context_profile, 
        GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float, 
        GLX_ARB_framebuffer_sRGB, GLX_ARB_get_proc_address, GLX_ARB_multisample, 
        GLX_EXT_buffer_age, GLX_EXT_create_context_es2_profile, 
        GLX_EXT_create_context_es_profile, GLX_EXT_fbconfig_packed_float, 
        GLX_EXT_framebuffer_sRGB, GLX_EXT_import_context, 
        GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
        GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
        GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
        GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control, 
        GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
        GLX_SGIX_visual_select_group, GLX_SGI_make_current_read, 
        GLX_SGI_swap_control, GLX_SGI_video_sync
    GLX version: 1.4
    GLX extensions:
        GLX_ARB_create_context, GLX_ARB_create_context_profile, 
        GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float, 
        GLX_ARB_framebuffer_sRGB, GLX_ARB_get_proc_address, GLX_ARB_multisample, 
        GLX_EXT_create_context_es2_profile, GLX_EXT_framebuffer_sRGB, 
        GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
        GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
        GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
        GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control, 
        GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
        GLX_SGIX_visual_select_group, GLX_SGI_make_current_read, 
        GLX_SGI_swap_control, GLX_SGI_video_sync
    Extended renderer info (GLX_MESA_query_renderer):
        Vendor: Intel Open Source Technology Center (0x8086)
        Device: Mesa DRI Intel(R) Ivybridge Mobile  (0x166)
        Version: 12.0.1
        Accelerated: yes
        Video memory: 1536MB
        Unified memory: yes
        Preferred profile: core (0x1)
        Max core profile version: 3.3
        Max compat profile version: 3.0
        Max GLES1 profile version: 1.1
        Max GLES[23] profile version: 3.0
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 12.0.1
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
        GL_3DFX_texture_compression_FXT1, GL_AMD_conservative_depth, 
        GL_AMD_draw_buffers_blend, GL_AMD_performance_monitor, 
        GL_AMD_seamless_cubemap_per_texture, GL_AMD_shader_trinary_minmax, 
        GL_AMD_vertex_shader_layer, GL_AMD_vertex_shader_viewport_index, 
        GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5, 
        GL_APPLE_object_purgeable, GL_ARB_ES2_compatibility, 
        GL_ARB_ES3_compatibility, GL_ARB_arrays_of_arrays, GL_ARB_base_instance, 
        GL_ARB_blend_func_extended, GL_ARB_buffer_storage, 
        GL_ARB_clear_buffer_object, GL_ARB_clear_texture, GL_ARB_clip_control, 
        GL_ARB_compressed_texture_pixel_storage, GL_ARB_compute_shader, 
        GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
        GL_ARB_copy_buffer, GL_ARB_copy_image, GL_ARB_cull_distance, 
        GL_ARB_debug_output, GL_ARB_depth_buffer_float, GL_ARB_depth_clamp, 
        GL_ARB_derivative_control, GL_ARB_direct_state_access, 
        GL_ARB_draw_buffers, GL_ARB_draw_buffers_blend, 
        GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect, 
        GL_ARB_draw_instanced, GL_ARB_explicit_attrib_location, 
        GL_ARB_explicit_uniform_location, GL_ARB_fragment_coord_conventions, 
        GL_ARB_fragment_layer_viewport, GL_ARB_fragment_shader, 
        GL_ARB_framebuffer_no_attachments, GL_ARB_framebuffer_object, 
        GL_ARB_framebuffer_sRGB, GL_ARB_get_program_binary, 
        GL_ARB_get_texture_sub_image, GL_ARB_gpu_shader5, GL_ARB_half_float_pixel, 
        GL_ARB_half_float_vertex, GL_ARB_instanced_arrays, 
        GL_ARB_internalformat_query, GL_ARB_internalformat_query2, 
        GL_ARB_invalidate_subdata, GL_ARB_map_buffer_alignment, 
        GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect, 
        GL_ARB_occlusion_query2, GL_ARB_pipeline_statistics_query, 
        GL_ARB_pixel_buffer_object, GL_ARB_point_sprite, 
        GL_ARB_program_interface_query, GL_ARB_provoking_vertex, 
        GL_ARB_robustness, GL_ARB_sample_shading, GL_ARB_sampler_objects, 
        GL_ARB_seamless_cube_map, GL_ARB_seamless_cubemap_per_texture, 
        GL_ARB_separate_shader_objects, GL_ARB_shader_atomic_counters, 
        GL_ARB_shader_bit_encoding, GL_ARB_shader_clock, 
        GL_ARB_shader_draw_parameters, GL_ARB_shader_image_load_store, 
        GL_ARB_shader_image_size, GL_ARB_shader_objects, 
        GL_ARB_shader_storage_buffer_object, GL_ARB_shader_subroutine, 
        GL_ARB_shader_texture_image_samples, GL_ARB_shader_texture_lod, 
        GL_ARB_shading_language_420pack, GL_ARB_shading_language_packing, 
        GL_ARB_sync, GL_ARB_tessellation_shader, GL_ARB_texture_barrier, 
        GL_ARB_texture_buffer_object, GL_ARB_texture_buffer_object_rgb32, 
        GL_ARB_texture_buffer_range, GL_ARB_texture_compression_bptc, 
        GL_ARB_texture_compression_rgtc, GL_ARB_texture_cube_map_array, 
        GL_ARB_texture_float, GL_ARB_texture_gather, 
        GL_ARB_texture_mirror_clamp_to_edge, GL_ARB_texture_multisample, 
        GL_ARB_texture_non_power_of_two, GL_ARB_texture_query_levels, 
        GL_ARB_texture_query_lod, GL_ARB_texture_rectangle, GL_ARB_texture_rg, 
        GL_ARB_texture_rgb10_a2ui, GL_ARB_texture_storage, 
        GL_ARB_texture_storage_multisample, GL_ARB_texture_swizzle, 
        GL_ARB_texture_view, GL_ARB_timer_query, GL_ARB_transform_feedback2, 
        GL_ARB_transform_feedback3, GL_ARB_transform_feedback_instanced, 
        GL_ARB_uniform_buffer_object, GL_ARB_vertex_array_bgra, 
        GL_ARB_vertex_array_object, GL_ARB_vertex_attrib_binding, 
        GL_ARB_vertex_shader, GL_ARB_vertex_type_10f_11f_11f_rev, 
        GL_ARB_vertex_type_2_10_10_10_rev, GL_ARB_viewport_array, 
        GL_ATI_blend_equation_separate, GL_ATI_texture_float, GL_EXT_abgr, 
        GL_EXT_blend_equation_separate, GL_EXT_draw_buffers2, 
        GL_EXT_draw_instanced, GL_EXT_framebuffer_blit, 
        GL_EXT_framebuffer_multisample, GL_EXT_framebuffer_multisample_blit_scaled, 
        GL_EXT_framebuffer_sRGB, GL_EXT_packed_depth_stencil, GL_EXT_packed_float, 
        GL_EXT_pixel_buffer_object, GL_EXT_polygon_offset_clamp, 
        GL_EXT_provoking_vertex, GL_EXT_shader_integer_mix, 
        GL_EXT_shader_samples_identical, GL_EXT_texture_array, 
        GL_EXT_texture_compression_dxt1, GL_EXT_texture_compression_rgtc, 
        GL_EXT_texture_compression_s3tc, GL_EXT_texture_filter_anisotropic, 
        GL_EXT_texture_integer, GL_EXT_texture_sRGB, GL_EXT_texture_sRGB_decode, 
        GL_EXT_texture_shared_exponent, GL_EXT_texture_snorm, 
        GL_EXT_texture_swizzle, GL_EXT_timer_query, GL_EXT_transform_feedback, 
        GL_EXT_vertex_array_bgra, GL_IBM_multimode_draw_arrays, 
        GL_INTEL_performance_query, GL_KHR_context_flush_control, GL_KHR_debug, 
        GL_KHR_robustness, GL_MESA_pack_invert, GL_MESA_texture_signed_rgba, 
        GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
        GL_NV_texture_barrier, GL_OES_EGL_image, GL_OES_read_format, GL_S3_s3tc

    OpenGL version string: 3.0 Mesa 12.0.1
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
        GL_3DFX_texture_compression_FXT1, GL_AMD_conservative_depth, 
        GL_AMD_draw_buffers_blend, GL_AMD_performance_monitor, 
        GL_AMD_seamless_cubemap_per_texture, GL_AMD_shader_trinary_minmax, 
        GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5, 
        GL_APPLE_object_purgeable, GL_APPLE_packed_pixels, 
        GL_APPLE_vertex_array_object, GL_ARB_ES2_compatibility, 
        GL_ARB_ES3_compatibility, GL_ARB_arrays_of_arrays, 
        GL_ARB_blend_func_extended, GL_ARB_buffer_storage, 
        GL_ARB_clear_buffer_object, GL_ARB_clear_texture, GL_ARB_clip_control, 
        GL_ARB_color_buffer_float, GL_ARB_compressed_texture_pixel_storage, 
        GL_ARB_compute_shader, GL_ARB_conditional_render_inverted, 
        GL_ARB_conservative_depth, GL_ARB_copy_buffer, GL_ARB_copy_image, 
        GL_ARB_cull_distance, GL_ARB_debug_output, GL_ARB_depth_buffer_float, 
        GL_ARB_depth_clamp, GL_ARB_depth_texture, GL_ARB_derivative_control, 
        GL_ARB_draw_buffers, GL_ARB_draw_buffers_blend, 
        GL_ARB_draw_elements_base_vertex, GL_ARB_draw_instanced, 
        GL_ARB_explicit_attrib_location, GL_ARB_explicit_uniform_location, 
        GL_ARB_fragment_coord_conventions, GL_ARB_fragment_program, 
        GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader, 
        GL_ARB_framebuffer_no_attachments, GL_ARB_framebuffer_object, 
        GL_ARB_framebuffer_sRGB, GL_ARB_get_program_binary, 
        GL_ARB_get_texture_sub_image, GL_ARB_half_float_pixel, 
        GL_ARB_half_float_vertex, GL_ARB_instanced_arrays, 
        GL_ARB_internalformat_query, GL_ARB_internalformat_query2, 
        GL_ARB_invalidate_subdata, GL_ARB_map_buffer_alignment, 
        GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multisample, 
        GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_occlusion_query2, 
        GL_ARB_pipeline_statistics_query, GL_ARB_pixel_buffer_object, 
        GL_ARB_point_parameters, GL_ARB_point_sprite, 
        GL_ARB_program_interface_query, GL_ARB_provoking_vertex, 
        GL_ARB_robustness, GL_ARB_sample_shading, GL_ARB_sampler_objects, 
        GL_ARB_seamless_cube_map, GL_ARB_seamless_cubemap_per_texture, 
        GL_ARB_separate_shader_objects, GL_ARB_shader_atomic_counters, 
        GL_ARB_shader_bit_encoding, GL_ARB_shader_clock, 
        GL_ARB_shader_draw_parameters, GL_ARB_shader_image_load_store, 
        GL_ARB_shader_image_size, GL_ARB_shader_objects, 
        GL_ARB_shader_storage_buffer_object, GL_ARB_shader_texture_image_samples, 
        GL_ARB_shader_texture_lod, GL_ARB_shading_language_100, 
        GL_ARB_shading_language_420pack, GL_ARB_shading_language_packing, 
        GL_ARB_shadow, GL_ARB_sync, GL_ARB_texture_barrier, 
        GL_ARB_texture_border_clamp, GL_ARB_texture_compression, 
        GL_ARB_texture_compression_bptc, GL_ARB_texture_compression_rgtc, 
        GL_ARB_texture_cube_map, GL_ARB_texture_cube_map_array, 
        GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
        GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3, 
        GL_ARB_texture_float, GL_ARB_texture_gather, 
        GL_ARB_texture_mirror_clamp_to_edge, GL_ARB_texture_mirrored_repeat, 
        GL_ARB_texture_multisample, GL_ARB_texture_non_power_of_two, 
        GL_ARB_texture_query_levels, GL_ARB_texture_query_lod, 
        GL_ARB_texture_rectangle, GL_ARB_texture_rg, GL_ARB_texture_rgb10_a2ui, 
        GL_ARB_texture_storage, GL_ARB_texture_storage_multisample, 
        GL_ARB_texture_swizzle, GL_ARB_texture_view, GL_ARB_timer_query, 
        GL_ARB_transform_feedback2, GL_ARB_transform_feedback3, 
        GL_ARB_transform_feedback_instanced, GL_ARB_transpose_matrix, 
        GL_ARB_uniform_buffer_object, GL_ARB_vertex_array_bgra, 
        GL_ARB_vertex_array_object, GL_ARB_vertex_attrib_binding, 
        GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader, 
        GL_ARB_vertex_type_10f_11f_11f_rev, GL_ARB_vertex_type_2_10_10_10_rev, 
        GL_ARB_window_pos, GL_ATI_blend_equation_separate, GL_ATI_draw_buffers, 
        GL_ATI_separate_stencil, GL_ATI_texture_env_combine3, 
        GL_ATI_texture_float, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, 
        GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, 
        GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array, 
        GL_EXT_copy_texture, GL_EXT_draw_buffers2, GL_EXT_draw_instanced, 
        GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_blit, 
        GL_EXT_framebuffer_multisample, GL_EXT_framebuffer_multisample_blit_scaled, 
        GL_EXT_framebuffer_object, GL_EXT_framebuffer_sRGB, 
        GL_EXT_gpu_program_parameters, GL_EXT_multi_draw_arrays, 
        GL_EXT_packed_depth_stencil, GL_EXT_packed_float, GL_EXT_packed_pixels, 
        GL_EXT_pixel_buffer_object, GL_EXT_point_parameters, 
        GL_EXT_polygon_offset, GL_EXT_polygon_offset_clamp, 
        GL_EXT_provoking_vertex, GL_EXT_rescale_normal, GL_EXT_secondary_color, 
        GL_EXT_separate_specular_color, GL_EXT_shader_integer_mix, 
        GL_EXT_shader_samples_identical, GL_EXT_shadow_funcs, 
        GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_subtexture, 
        GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_array, 
        GL_EXT_texture_compression_dxt1, GL_EXT_texture_compression_rgtc, 
        GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map, 
        GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add, 
        GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, 
        GL_EXT_texture_filter_anisotropic, GL_EXT_texture_integer, 
        GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle, 
        GL_EXT_texture_sRGB, GL_EXT_texture_sRGB_decode, 
        GL_EXT_texture_shared_exponent, GL_EXT_texture_snorm, 
        GL_EXT_texture_swizzle, GL_EXT_timer_query, GL_EXT_transform_feedback, 
        GL_EXT_vertex_array, GL_EXT_vertex_array_bgra, 
        GL_IBM_multimode_draw_arrays, GL_IBM_rasterpos_clip, 
        GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate, 
        GL_INTEL_performance_query, GL_KHR_context_flush_control, GL_KHR_debug, 
        GL_KHR_robustness, GL_MESA_pack_invert, GL_MESA_texture_signed_rgba, 
        GL_MESA_window_pos, GL_NV_blend_square, GL_NV_conditional_render, 
        GL_NV_depth_clamp, GL_NV_light_max_exponent, GL_NV_packed_depth_stencil, 
        GL_NV_primitive_restart, GL_NV_texgen_reflection, GL_NV_texture_barrier, 
        GL_NV_texture_env_combine4, GL_NV_texture_rectangle, GL_OES_EGL_image, 
        GL_OES_read_format, GL_S3_s3tc, GL_SGIS_generate_mipmap, 
        GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp, 
        GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays

    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 12.0.1
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    OpenGL ES profile extensions:
        GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5, 
        GL_APPLE_texture_max_level, GL_EXT_blend_func_extended, 
        GL_EXT_blend_minmax, GL_EXT_clip_cull_distance, GL_EXT_color_buffer_float, 
        GL_EXT_discard_framebuffer, GL_EXT_draw_buffers, 
        GL_EXT_draw_buffers_indexed, GL_EXT_draw_elements_base_vertex, 
        GL_EXT_map_buffer_range, GL_EXT_multi_draw_arrays, 
        GL_EXT_polygon_offset_clamp, GL_EXT_read_format_bgra, 
        GL_EXT_separate_shader_objects, GL_EXT_shader_integer_mix, 
        GL_EXT_texture_border_clamp, GL_EXT_texture_compression_dxt1, 
        GL_EXT_texture_filter_anisotropic, GL_EXT_texture_format_BGRA8888, 
        GL_EXT_texture_rg, GL_EXT_texture_sRGB_decode, 
        GL_EXT_texture_type_2_10_10_10_REV, GL_EXT_unpack_subimage, 
        GL_INTEL_performance_query, GL_KHR_context_flush_control, GL_KHR_debug, 
        GL_KHR_robustness, GL_NV_draw_buffers, GL_NV_fbo_color_attachments, 
        GL_NV_read_buffer, GL_NV_read_depth, GL_NV_read_depth_stencil, 
        GL_NV_read_stencil, GL_OES_EGL_image, GL_OES_EGL_image_external, 
        GL_OES_EGL_sync, GL_OES_compressed_ETC1_RGB8_texture, GL_OES_depth24, 
        GL_OES_depth_texture, GL_OES_depth_texture_cube_map, 
        GL_OES_draw_buffers_indexed, GL_OES_draw_elements_base_vertex, 
        GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 
        GL_OES_get_program_binary, GL_OES_mapbuffer, GL_OES_packed_depth_stencil, 
        GL_OES_rgb8_rgba8, GL_OES_sample_shading, GL_OES_sample_variables, 
        GL_OES_shader_multisample_interpolation, GL_OES_standard_derivatives, 
        GL_OES_stencil8, GL_OES_surfaceless_context, GL_OES_texture_3D, 
        GL_OES_texture_border_clamp, GL_OES_texture_float, 
        GL_OES_texture_float_linear, GL_OES_texture_half_float, 
        GL_OES_texture_half_float_linear, GL_OES_texture_npot, 
        GL_OES_vertex_array_object

    40 GLX Visuals
        visual  x   bf lv rg d st  colorbuffer  sr ax dp st accumbuffer  ms  cav
      id dep cl sp  sz l  ci b ro  r  g  b  a F gb bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------------
    0x020 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x021 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x0af 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x0b0 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x0b1 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x0b2 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x0b3 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x0b4 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x0b5 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x0b6 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow
    0x0b7 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x0b8 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8 16 16 16  0  0 0 Slow
    0x0b9 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  4 1 None
    0x0ba 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  8 1 None
    0x0bb 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  4 1 None
    0x0bc 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  8 1 None
    0x0bd 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  4 1 None
    0x0be 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  8 1 None
    0x0bf 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  4 1 None
    0x0c0 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  8 1 None
    0x0c1 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x0c2 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x0c3 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x0c4 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x0c5 24 dc  0  24  0 r  . .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x0c6 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x0c7 24 dc  0  24  0 r  . .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x0c8 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x0c9 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow
    0x0ca 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x0cb 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8 16 16 16  0  0 0 Slow
    0x0cc 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  4 1 None
    0x0cd 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  8 1 None
    0x0ce 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  4 1 None
    0x0cf 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  8 1 None
    0x0d0 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  4 1 None
    0x0d1 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  8 1 None
    0x0d2 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  4 1 None
    0x0d3 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  8 1 None
    0x06e 32 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None

    64 GLXFBConfigs:
        visual  x   bf lv rg d st  colorbuffer  sr ax dp st accumbuffer  ms  cav
      id dep cl sp  sz l  ci b ro  r  g  b  a F gb bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------------
    0x06f  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x070  0 tc  0  16  0 r  . .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x071  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
    0x072  0 tc  0  16  0 r  . .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
    0x073  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x074  0 tc  0  16  0 r  . .   5  6  5  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x075 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x076 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x077 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x078 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x079 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x07a 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x07b 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x07c 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x07d  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
    0x07e  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0 16 16 16  0  0 0 Slow
    0x07f 32 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x080 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow
    0x081 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x082 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8 16 16 16  0  0 0 Slow
    0x083  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  4 1 None
    0x084  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  8 1 None
    0x085  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  4 1 None
    0x086  0 tc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  8 1 None
    0x087 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  4 1 None
    0x088 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  8 1 None
    0x089 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  4 1 None
    0x08a 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  8 1 None
    0x08b 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  4 1 None
    0x08c 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  8 1 None
    0x08d 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  4 1 None
    0x08e 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  8 1 None
    0x08f  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x090  0 dc  0  16  0 r  . .   5  6  5  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x091  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
    0x092  0 dc  0  16  0 r  . .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
    0x093  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x094  0 dc  0  16  0 r  . .   5  6  5  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x095 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x096 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
    0x097 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x098 24 dc  0  32  0 r  . .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x099 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x09a 24 dc  0  24  0 r  . .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
    0x09b 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x09c 24 dc  0  24  0 r  . .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x09d  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  0 0 None
    0x09e  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0 16 16 16  0  0 0 Slow
    0x09f 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
    0x0a0 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8 16 16 16 16  0 0 Slow
    0x0a1 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  0 0 None
    0x0a2 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8 16 16 16  0  0 0 Slow
    0x0a3  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  4 1 None
    0x0a4  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0  0  0  0  0  0  0  8 1 None
    0x0a5  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  4 1 None
    0x0a6  0 dc  0  16  0 r  y .   5  6  5  0 .  .  0 16  0  0  0  0  0  8 1 None
    0x0a7 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  4 1 None
    0x0a8 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  8 1 None
    0x0a9 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  4 1 None
    0x0aa 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  8 1 None
    0x0ab 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  4 1 None
    0x0ac 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  8 1 None
    0x0ad 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  4 1 None
    0x0ae 24 dc  0  24  0 r  y .   8  8  8  0 .  .  0 24  8  0  0  0  0  8 1 None

## uname -a

    Linux Gentoo 4.5.2-1 #1 SMP Thu May 26 11:14:14 VET 2016 x86_64 Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz GenuineIntel GNU/Linux
Comment 15 Jason Ekstrand 2016-07-26 14:53:16 UTC
(In reply to Edinson E. Padrón Urdaneta from comment #14)
> The game doesn't work for me either. Next is the relevant information:
>
> [...] 
>
>     vulkan: No DRI3 support
>     The selected graphics queue does not support presenting a swapchain
> image.
>     vulkan/renderdevicevulkan.cpp 1041 CreateSwapChain():
>     The selected graphics queue does not support presenting a swapchain
> image.

The "no DRI3 support" message is key here.  You need to have DRI3 enabled in your X server for Vulkan apps to work.  They do not work with DRI2.
Comment 16 Edinson E. Padrón Urdaneta 2016-07-29 23:59:10 UTC
> The "no DRI3 support" message is key here.  You need to have DRI3 enabled in
> your X server for Vulkan apps to work.  They do not work with DRI2.

Is there a way to check for such support? I'm on Gentoo/Funtoo and I built mesa with the dri3 flag on.

I tried running the demos from Sascha Willems. And every single of them threw an error saying the support on IvyBridge is incomplete. That could be the real reason but I'm just guessing.

Thank you for your reply.
Comment 17 Edinson E. Padrón Urdaneta 2016-07-30 04:13:27 UTC
> Is there a way to check for such support? I'm on Gentoo/Funtoo and I built
> mesa with the dri3 flag on.

Yes in deed: `env LIBGL_DEBUG=verbose glxinfo | grep libgl`

Just as Jason Ekstrand said, I was lacking of DRI3 support.

> I tried running the demos from Sascha Willems. And every single of them
> threw an error saying the support on IvyBridge is incomplete. That could be
> the real reason but I'm just guessing.

Now they work. A few doesn't work pretty well but it's progress.

Sadly, Dota2 just shows a black screen.
Comment 18 mrc_munir 2017-02-16 08:41:42 UTC
For Ivy bridge it's working in the actual code can't crash but letters glitch can't load

the log by game Only see return 

ERROR! VK call failed! result = VK_ERROR_OUT_OF_DEVICE_MEMORY ( vkQueueSubmit( VulkanQueue(), 1, &submitInfo, pFence->Get() ) )
ERROR! VK call failed! result = VK_ERROR_OUT_OF_DEVICE_MEMORY ( vkQueueSubmit( VulkanQueue(), 1, &submitInfo, pFence->Get() ) )
ERROR! VK call failed! result = VK_ERROR_OUT_OF_DEVICE_MEMORY ( vkQueueSubmit( VulkanQueue(), 1, &submitInfo, presentFence.m_pFence ) )
Comment 19 Paul 2019-09-05 08:47:12 UTC
Hello guys
I've rechecked the issue on my IVB (Intel® HD Graphics 2500) with the latest master version of the Mesa - Dota2 looks good.
I close the issue as WORKSFORME, feel free to reopen the issue if you still have a problems with it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.