Bug 96390 - [GK208] DISP failure while using PRIME offloading
Summary: [GK208] DISP failure while using PRIME offloading
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-05 16:21 UTC by Ilia Mirkin
Modified: 2016-06-05 16:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
disp error dump (4.21 KB, text/plain)
2016-06-05 16:21 UTC, Ilia Mirkin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilia Mirkin 2016-06-05 16:21:31 UTC
Created attachment 124333 [details]
disp error dump

With a GK208B (NV106) and GT215 (NVA3) [and NV34] plugged in, I went to run warsow 2.1 with DRI_PRIME=1 (to offload onto the GT215). I got this error and a hung display. 02:00:00 is the GK208 (which is where the monitor is connected):

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208 [GeForce GT 730] [10de:1287] (rev a1)
04:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT215 [GeForce GT 240] [10de:0ca3] (rev a2)
09:01.0 VGA compatible controller [0300]: NVIDIA Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)

Note the "moving pinned object" note too - can't be good. This happened right as I launched warsow, the picture left-over on the desktop was one of my original desktop, shifted up by 16-32 pixels. (And I could see the original bottom pixels duplicated.)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.