Bug 96411 - [NVA8] reclocking not working. screen glitches.
Summary: [NVA8] reclocking not working. screen glitches.
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Roy
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-06 17:23 UTC by J. Neto
Modified: 2016-06-06 19:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
NVS 3100m vbios dump (62.50 KB, application/octet-stream)
2016-06-06 17:26 UTC, J. Neto
no flags Details
mmio trace (3.81 MB, application/x-xz)
2016-06-06 17:32 UTC, J. Neto
no flags Details
nouveau kmsgs (1.32 KB, text/plain)
2016-06-06 17:44 UTC, J. Neto
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description J. Neto 2016-06-06 17:23:44 UTC
Reclocking isn't working in linux 4.4 and 4.5, 4.3 is ok. I didn't test linux 4.6. 

Right after echo 03 > pstate the screen glitches, but I'm able to safe reboot by sysrq method.

There are no errors on the log.
Comment 1 J. Neto 2016-06-06 17:26:27 UTC
Created attachment 124370 [details]
NVS 3100m vbios dump

in: nvapeek 0x101000
out: 00101000: 8f78b098
Comment 2 J. Neto 2016-06-06 17:32:54 UTC
Created attachment 124371 [details]
mmio trace

in: uname -a
out: Linux t410 4.4.9-300.fc23.x86_64 #1 SMP Mon Feb 1 03:18:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

in: ???
out: nvidia-340xx-340.96

I've followed this guide: https://wiki.ubuntu.com/X/MMIOTracing

And during the tracing I've run: xinit -e sh -c "glxgears & sleep 10"
Comment 3 J. Neto 2016-06-06 17:44:16 UTC
Created attachment 124372 [details]
nouveau kmsgs

In the boot after the bug I've run: journalctl -b -1 -o cat | grep nouveau


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.