Bug 96425 - [bisected] occasional dark render in The Talos Principle
Summary: [bisected] occasional dark render in The Talos Principle
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-07 13:41 UTC by Grazvydas Ignotas
Modified: 2016-06-20 22:58 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot (56.32 KB, image/jpeg)
2016-06-07 13:41 UTC, Grazvydas Ignotas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grazvydas Ignotas 2016-06-07 13:41:26 UTC
Created attachment 124387 [details]
screenshot

After some recent game's update the game renders way too dark when viewing certain objects. The problem goes away or reappears depending on camera position. Reproduces on both Haswell and Skylake, works fine on r600g and llvmpipe. Mesa 10.1.3 does not have such problems so I've ran a bisect:

commit d47405eb707b9921f70454049677a9d504ee3fa6
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Fri Apr 10 16:24:11 2015 -0700

    i965: Use NIR by default for fragment shaders

Unfortunately the trace is rather large because the problem usually shows up further from save points. It shows up in the last frame of this trace:
https://drive.google.com/file/d/0Bz8fw_SGGDzsejZiR1Y1anN3aHM/view?usp=sharing
Comment 1 Jason Ekstrand 2016-06-19 01:25:09 UTC
There's now a patch on the mailing list that should fix this:

https://lists.freedesktop.org/archives/mesa-dev/2016-June/120874.html
Comment 2 Jason Ekstrand 2016-06-20 18:57:48 UTC
This should be fixed by the following commit:

commit 68e308d85355079ad93bd4e16cba164784740fdf
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Sat Jun 18 12:30:36 2016 -0700

    nir/algebraic: Remove imprecise flog2 optimizations
Comment 3 Grazvydas Ignotas 2016-06-20 22:58:00 UTC
Confirmed, thanks, but the game still shows similar symptoms, bug 96607 filled.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.