Bug 96496 - Cannot compile xdvi on Snow Leopard and run on El Capitan
Summary: Cannot compile xdvi on Snow Leopard and run on El Capitan
Status: RESOLVED DUPLICATE of bug 96292
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.9 (xserver-1.17.4)
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-11 19:25 UTC by Richard Koch
Modified: 2016-06-12 04:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Koch 2016-06-11 19:25:34 UTC
I create MacTeX for the TeX User Group. I compile 64 bit binaries on OS X 10.6.8; these
run on all later systems. With XQuartz 2.7.8, this year's releasse of xdvi works fine, but with XQuart 2.7.9, it crashes:

xdvi-xaw 22.87.03 (Xaw toolkit): ../../../texk/xdvik/events.c:4450: Shouldn't happen: Segmentation fault - trying to clean up and aborting ...
Abort trap: 6

Recompiling xdvi directly on El Capitan produces a binary that works (only xdvi-xaw
needs to be updated). However, as expected this binary fails on older systems.

I installed XQuartz 2.7.9 on Snow Leopard and recompiled TeX Live. The resulting binary then ran on Snow Leopard and earlier systems, even without updating XQuartz. 
This binary ran on El Capitan with XQuartz 2.7.8, but failed as above with
XQuartz 2.7.9.

Hence it is impossible to produce a binary of xdvi which works with all the systems we support and XQuartz 2.7.9.
Comment 1 Jeremy Huddleston Sequoia 2016-06-12 04:31:57 UTC

*** This bug has been marked as a duplicate of bug 96292 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.