Bug 96516 - [bisected: 482526] "clover: Update OpenCL version string to match OpenGL": clover's build fails because of missing git_sha1.h
Summary: [bisected: 482526] "clover: Update OpenCL version string to match OpenGL": cl...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Vedran Miletić
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-13 23:27 UTC by Alexandre Demers
Modified: 2016-06-14 11:38 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Demers 2016-06-13 23:27:46 UTC
git_sha1.h is missing when clover's build is being called. git_sha1.h is either not built yet or the dependency it is looking for is at the wrong place.

You may need to git clean first to reproduce this, otherwise it may work with a previously generated git_sha1.h.

---
../../../../.././src/gallium/state_trackers/clover/api/platform.cpp:25:22: fatal error: git_sha1.h: No such file or directory
 #include "git_sha1.h"
                      ^
compilation terminated.
Makefile:932: recipe for target 'api/libclover_la-platform.lo' failed
make[4]: *** [api/libclover_la-platform.lo] Error 1
---

First bad commit

clover: Update OpenCL version string to match OpenGL
Committer Francisco Jerez<currojerez@riseup.net>
Author Vedran Miletić<vedran@miletic.net>
Author date 16-06-06 06:43
Parent i965/fs: Fix regs_written for SIMD-lowered instructions s...

    clover: Update OpenCL version string to match OpenGL
    
    Change MESA into Mesa in CL_PLATFORM_VERSION and CL_DEVICE_VERSION. For
    both, always append git version suffix from git_sha1.h.
    
    v5: move semicolon to same line as MESA_GIT_SHA1.
    v4: drop #ifdef guards.
    v3: add missing include.
    v2: change CL_DEVICE_VERSION as well.
    
    Cc: <mesa-stable@lists.freedesktop.org>
    Reviewed-by: Francisco Jerez <currojerez@riseup.net>
Comment 1 Vedran Miletić 2016-06-14 00:09:24 UTC
I am not very familiar with Mesa's build system, but will try to reproduce and fix this.
Comment 2 Emil Velikov 2016-06-14 00:13:35 UTC
Vedran friendly advice - changing assignee to yourself, limits notifications to others as the bug evolves. Some people just state that they're working on it, without changing the status. Feel free to proceed as you wish.

Alexandre, I take it that things were working just before that patch ? Are you using git checkouts, git archive or any other means to get (and build) mesa ?
Comment 3 Alexandre Demers 2016-06-14 02:32:49 UTC
(In reply to Emil Velikov from comment #2)
> Vedran friendly advice - changing assignee to yourself, limits notifications
> to others as the bug evolves. Some people just state that they're working on
> it, without changing the status. Feel free to proceed as you wish.
> 
> Alexandre, I take it that things were working just before that patch ? Are
> you using git checkouts, git archive or any other means to get (and build)
> mesa ?

Building mesa from git through git checkout, pull, and so on. Bisected in no time because I had just built mesa (64bit) (from culprit commit's parent) when I saw there was a new commit in the tree once I moved to build the 32 bit version. Previous commit was building without problem (and is still, I just tested it). It happened that I had made a clean up of the repo to build against an updated LLVM and I was lucky to find there was a missing git_sha1.h file.

If needed, I can provide my build script and/or autogen.sh command, but building from a clean repo should be enough to reproduce the problem.
Comment 4 Alexandre Demers 2016-06-14 02:36:42 UTC
As a cue, it may be similar to bug 50976.
Comment 5 Aaron Watry 2016-06-14 02:39:25 UTC
The issue manifests itself with an out-of-tree build that includes clover.  I'll be sending a patch to the list momentarily.
Comment 6 Michel Dänzer 2016-06-14 03:14:53 UTC
Module: Mesa
Branch: master
Commit: fafe026dbe0680c971bf3ba2452954eea84287f2
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=fafe026dbe0680c971bf3ba2452954eea84287f2

Author: Aaron Watry <awatry@gmail.com>
Date:   Mon Jun 13 21:46:33 2016 -0500

clover: Include generated sources in AM_CPPFLAGS
Comment 7 Vedran Miletić 2016-06-14 11:38:07 UTC
Aaron, thanks for fixing this.


bug/show.html.tmpl processed on Jan 22, 2017 at 22:23:56.
(provided by the Example extension).