Bug 96553 - Xorg freezes
Summary: Xorg freezes
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-16 11:45 UTC by Agostino Sarubbo
Modified: 2016-10-28 14:35 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.log (40.87 KB, text/plain)
2016-06-16 11:45 UTC, Agostino Sarubbo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo 2016-06-16 11:45:00 UTC
Created attachment 124556 [details]
Xorg.log

Hello, I get a freeze, I'm able to move the mouse cursor but nothing else.

I'm able to access via ssh and get the Xorg.log. I enabled the debug to have a more valid backtrace.

Feel free to ask whatever you need.
Comment 1 Agostino Sarubbo 2016-06-28 12:27:49 UTC
When the problem happens, In dmesg there is the following messages:

[11449.585126] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
[11449.585132] nouveau 0000:01:00.0: fifo: sw engine fault on channel 2, recovering...
[11451.584882] nouveau 0000:01:00.0: fifo: runlist 0 update timeout
[11453.880225] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]

bug 72180 seems to mention the same message error, but that bug was resolved as INVALID
I didn't read all comments, but the last comment seems to indicate that the problem is fixed in 4.1.
I'm using 4.4 and it is not fixed here.
Comment 2 simonF 2016-10-28 14:35:24 UTC
I have same trouble my computer freeze, I can mouve mouse but nothing else. in my log:

Oct 28 16:07:12 simon-Precision-T1700 kernel: [ 2191.290651] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct 28 16:07:12 simon-Precision-T1700 kernel: [ 2191.290656] nouveau 0000:01:00.0: fifo: sw engine fault on channel 7,
recovering...
Oct 28 16:07:14 simon-Precision-T1700 kernel: [ 2193.290170] nouveau 0000:01:00.0: fifo: runlist 0 update timeout
Oct 28 16:07:16 simon-Precision-T1700 kernel: [ 2195.585187] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct 28 16:07:21 simon-Precision-T1700 kernel: [ 2199.879719] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct 28 16:07:25 simon-Precision-T1700 kernel: [ 2204.174252] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]

I use a Nvidia Qudro K600:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107GL [Quadro K600] (rev a1)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.