Bug 96630 - [bdw] Hang in Challenge
Summary: [bdw] Hang in Challenge
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium blocker
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-22 06:02 UTC by ycui6
Modified: 2019-07-15 13:08 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: GPU hang


Attachments
gpu hang err log (3.67 MB, text/plain)
2016-06-22 06:02 UTC, ycui6
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ycui6 2016-06-22 06:02:46 UTC
Created attachment 124653 [details]
gpu hang err log

Platform is Intel BSW. 
Use 01.org open source graphics stack.
Try mult-path video playback decode + scaling + display.
Comment 1 ycui6 2016-06-22 06:03:58 UTC
kmsg print as
[58503.223700] [drm] stuck on render ring
[58503.246340] [drm] GPU HANG: ecode 8:0:0x7f1d7e3d, in Challenge [3259], reason: Ring hung, action: reset
[58503.246347] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[58503.246349] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[58503.246350] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[58503.246352] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[58503.246354] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[58503.248749] drm/i915: Resetting chip after gpu hang
[58509.215508] [drm] stuck on render ring
[58509.234297] [drm] GPU HANG: ecode 8:0:0x141cc731, reason: Ring hung, action: reset
[58509.237577] drm/i915: Resetting chip after gpu hang
[58515.215330] [drm] stuck on render ring
[58515.234061] [drm] GPU HANG: ecode 8:0:0x141cc731, reason: Ring hung, action: reset
[58515.234635] [drm:i915_set_reset_status] *ERROR* gpu hanging too fast, banning!
[58515.237403] drm/i915: Resetting chip after gpu hang
[58521.227151] [drm] stuck on render ring
[58521.245432] [drm] GPU HANG: ecode 8:0:0x141cc731, reason: Ring hung, action: reset
[58521.249139] drm/i915: Resetting chip after gpu hang
[58527.226887] [drm] stuck on render ring
[58527.245186] [drm] GPU HANG: ecode 8:0:0x141cc731, reason: Ring hung, action: reset
[58527.247960] drm/i915: Resetting chip after gpu hang
…
[58527.226887] [drm] stuck on render ring
[58527.245186] [drm] GPU HANG: ecode 8:0:0x141cc731, reason: Ring hung, action: reset
[58527.247960] drm/i915: Resetting chip after gpu hang
Comment 2 dog 2017-02-01 20:51:11 UTC
Can you retest with the latest graphics driver/media stack to see if this is still an issue?
Comment 3 Mark Janes 2017-02-07 22:41:36 UTC
Unless this is an opensource program, we will need an apitrace to reproduce:

http://apitrace.github.io/
Comment 4 Paul 2019-04-30 09:14:36 UTC
Hi guys
I've tried to find this program on the Internet, but unfortunately, I haven't.
So, Ycui6, if the issue still actual, could you please provide a link to the soft or write the way for installing this program.
Thanks.
Comment 5 Paul 2019-07-15 13:05:16 UTC
Since there is no answer, I'm closing the ticket.
Fill free to reopen it if the issue is still actual.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.