Bug 96664 - [CHV] Missing text when many fonts are loaded
Summary: [CHV] Missing text when many fonts are loaded
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-24 04:32 UTC by Stephen Just
Modified: 2017-07-24 23:15 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: display/atomic


Attachments
Screenshot (89.35 KB, image/png)
2016-06-24 04:32 UTC, Stephen Just
no flags Details
i915_gem_gtt (110.71 KB, text/plain)
2016-06-24 04:34 UTC, Stephen Just
no flags Details
intel_reg dump (93.54 KB, text/plain)
2016-06-24 04:34 UTC, Stephen Just
no flags Details
dmesg (66.33 KB, text/plain)
2016-06-24 04:36 UTC, Stephen Just
no flags Details
i915_opregion (8.00 KB, text/plain)
2016-06-24 04:47 UTC, Stephen Just
no flags Details
xorg.log (34.91 KB, text/plain)
2016-06-24 16:08 UTC, Stephen Just
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Just 2016-06-24 04:32:50 UTC
Created attachment 124694 [details]
Screenshot

On Surface 3, in certain circumstances - primarily when there are a variety of fonts being displayed at once - certain letters do not render on screen. A particularly severe instance is shown in the attached screenshot.

This occurs both on kernel 4.7-rc4 and drm-intel-nightly-20160623. using latest xorg driver.

Other instances of similar behavior have been reported with other graphics cards in the past and in most of them it seemed to be an issue with handling of video memory. As such, I suspect something similar is happening here - perhaps running out of video memory?

I will attach some debug info that I think would be relevant.
Comment 1 Stephen Just 2016-06-24 04:34:11 UTC
Created attachment 124695 [details]
i915_gem_gtt

GTT:
"Total 720 objects, 493879296 bytes, 214650880 GTT size"
Comment 2 Stephen Just 2016-06-24 04:34:41 UTC
Created attachment 124696 [details]
intel_reg dump
Comment 3 Stephen Just 2016-06-24 04:36:14 UTC
Created attachment 124697 [details]
dmesg
Comment 4 Stephen Just 2016-06-24 04:47:01 UTC
Created attachment 124698 [details]
i915_opregion
Comment 5 Chris Wilson 2016-06-24 07:06:13 UTC
That gtt layout is pretty inefficient. Please attach your xorg.log.
Comment 6 Stephen Just 2016-06-24 16:08:23 UTC
Created attachment 124706 [details]
xorg.log

As requested, xorg.log
Comment 7 yann 2016-07-11 14:18:04 UTC
from kernel log we can see (ignoring dsi lp error) 
[  922.757079] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B (start=1522 end=1523) time 8 us, min 1271, max 1279, scanline start 1280, end 1280
 so can it be linked to this "refresh" issue? 

could it be also a duplicate of 95632?
Comment 8 Chris Wilson 2016-07-11 20:19:49 UTC
(In reply to yann from comment #7)
> from kernel log we can see (ignoring dsi lp error) 
> [  922.757079] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update
> failure on pipe B (start=1522 end=1523) time 8 us, min 1271, max 1279,
> scanline start 1280, end 1280
>  so can it be linked to this "refresh" issue? 
> 
> could it be also a duplicate of 95632?

No. glyphs are missing from the glyph cache. Either the data was corrupted before it was uploaded, the render into the cache failed or the cache has been overwritten. The logic is the same for all gpu's, the only thing that varies is the rendering engine (though that is shared is bdw), the gpu itself and the environment.
Comment 9 Jari Tahvanainen 2016-12-09 15:56:33 UTC
Stephen - any news (new information) related to this? There has been some updates/fixes on "Atomic update failure on pipe" area ...
Comment 10 Rami 2017-03-06 15:20:32 UTC
Hi, many improvements pushed in kernel recently so can you try to retest whith latest drm-tip kernel from (https://cgit.freedesktop.org/drm-tip branch drm-tip). Boot with drm.debug=0x1e and attach the dmesg if you reproduce this bug. thnks
Comment 11 Jari Tahvanainen 2017-04-19 14:32:42 UTC
Timeout - marking as resolved+fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.