Bug 96825 - anv_device.c:31:27: fatal error: anv_timestamp.h: No such file or directory
Summary: anv_device.c:31:27: fatal error: anv_timestamp.h: No such file or directory
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Emil Velikov
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-07-05 16:51 UTC by Vinson Lee
Modified: 2016-07-06 18:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2016-07-05 16:51:17 UTC
mesa: aa7d42a5f9d8f491ca3a1fdaa61ee7058398f80f (master 12.1.0-devel)

  CC       anv_device.lo
anv_device.c:31:27: fatal error: anv_timestamp.h: No such file or directory
Comment 1 Jason Ekstrand 2016-07-05 17:28:39 UTC
A bit more information would probably be useful. In-tree or out? Can you provide a build log?
Comment 2 Vinson Lee 2016-07-05 17:53:06 UTC
$ ./autogen.sh --with-dri-drivers=i965 --with-gallium-drivers= --with-vulkan-drivers=intel
$ make
[...]
  CC       anv_gem.lo
  CC       anv_entrypoints.lo
  CC       anv_allocator.lo
  CC       anv_batch_chain.lo
  CC       anv_cmd_buffer.lo
  CC       anv_descriptor_set.lo
  CC       anv_device.lo
  CC       anv_dump.lo
anv_device.c:31:27: fatal error: anv_timestamp.h: No such file or directory
Comment 3 Emil Velikov 2016-07-05 19:12:59 UTC
Jason, guess that your "a bit" was taken too literally ;-)

Vinson, which distribution is this on, does any other platforms have this issue ?

Does the system in question have access to 'date' ? If not I'd strongly recommend installing a new enough version of the coreutil package.

If `date' is available, please provide the output of `make V=1' after the failed build (to keep the log short). If you do a quick search in srcdir & builddir for anv_timestamp.h that'll also be nice. 


Thanks
Comment 4 Vinson Lee 2016-07-05 19:41:17 UTC
The build error occurs on both Ubuntu and Fedora.
Comment 5 Emil Velikov 2016-07-06 11:04:41 UTC
> Does the system in question have access to 'date' ? If not I'd strongly
> recommend installing a new enough version of the coreutil package.
> 
> If `date' is available, please provide the output of `make V=1' after the
> failed build (to keep the log short). If you do a quick search in srcdir &
> builddir for anv_timestamp.h that'll also be nice. 
> 
Vinson, can you help out with these ?

Looking at the successful oibaf PPA builds [1], I'm inclined that this is not something affecting wide range of people/setups, but specific to your setup(s) ? The above questions/suggestions will help track it down. 

Can one have access to the affected setups/machines ? Alternatively is there an vmware/vbox image that one could use to achieve the above results ?

[1] https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers/+packages
Comment 6 Emil Velikov 2016-07-06 18:15:05 UTC
Update, things were passing due to bugs on our/my end. Should be fixed with

commit 9618e2a24c18b5bbc9ff872d1f6870261d14dee5
Author: Emil Velikov <emmil.velikov@collabora.com>
Date:   Wed Jul 6 16:18:21 2016 +0100

    anv: vulkan: remove the anv_device.$(OBJEXT) rule


bug/show.html.tmpl processed on Feb 19, 2017 at 16:41:35.
(provided by the Example extension).