Bug 96908 - [radeonsi] MSAA causes graphical artifacts
Summary: [radeonsi] MSAA causes graphical artifacts
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-12 20:26 UTC by Andrey Vaynberger
Modified: 2016-07-23 13:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
artifacts in The Talos Principle (1.26 MB, image/png)
2016-07-12 20:26 UTC, Andrey Vaynberger
Details
Artifacts in Unigine Heaven (1.61 MB, image/png)
2016-07-12 20:28 UTC, Andrey Vaynberger
Details
glxinfo64 output (99.90 KB, text/plain)
2016-07-12 20:29 UTC, Andrey Vaynberger
Details
dmesg output (74.80 KB, text/plain)
2016-07-12 20:32 UTC, Andrey Vaynberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Vaynberger 2016-07-12 20:26:03 UTC
Created attachment 125035 [details]
artifacts in The Talos Principle

When I enable MSAA (x2, x4 or x8) in the Unigine Heaven or in The Talos Principle (I haven't tried other games yet) I get graphical artifacts. You can see them on the attached screenshots.

GPU: AMD RX480
OS: Fedora 25
Mesa version:  git b479c47
LLVM version: svn 275001
Kernel version: 4.7.0-rc6
linux-firmware: git a141500
Comment 1 Andrey Vaynberger 2016-07-12 20:28:04 UTC
Created attachment 125036 [details]
Artifacts in Unigine Heaven
Comment 2 Andrey Vaynberger 2016-07-12 20:29:12 UTC
Created attachment 125037 [details]
glxinfo64 output
Comment 3 Andrey Vaynberger 2016-07-12 20:32:10 UTC
Created attachment 125038 [details]
dmesg output
Comment 4 Nicolai Hähnle 2016-07-13 09:05:46 UTC
Hi Andrey, thanks for the report.

I just tried Unigine Heaven with x8 on Tonga, and see no such problems. I'm also fairly certain that I tried MSAA in Heaven on Polaris10 and so no such problems, but I'll re-try when I get the change. I'll keep you posted.
Comment 5 Nicolai Hähnle 2016-07-13 09:07:10 UTC
Sorry, forgot to mention: could you provide an apitrace of The Talos Principle that shows the artifacts on your system? Upload e.g. to Google Drive since it's going to be fairly large.
Comment 6 Nicolai Hähnle 2016-07-13 09:26:00 UTC
Never mind, I see them in Unigine Heaven on Polaris10 as well. Must be a recent regression.
Comment 7 Andrey Vaynberger 2016-07-13 19:20:46 UTC
The apitrace of The Talos Principle: https://drive.google.com/open?id=0BzMT1H8Zl-hEeXBhSUxqQkM1dEk. Just in case.
Comment 8 Nicolai Hähnle 2016-07-16 18:45:24 UTC
The patch at https://patchwork.freedesktop.org/patch/99101/ fixes the problem for me.
Comment 9 Andrey Vaynberger 2016-07-17 18:09:21 UTC
I confirm. The patch fixes the problem for me as well.
Comment 10 Nicolai Hähnle 2016-07-23 13:41:23 UTC
Mesa master commit f755da0f2f8609e603b50424aa254358eb72fa25


bug/show.html.tmpl processed on Mar 26, 2017 at 03:27:37.
(provided by the Example extension).