Bug 97014 - member of group dbus unable to push to dbus.git
Summary: member of group dbus unable to push to dbus.git
Status: VERIFIED FIXED
Alias: None
Product: freedesktop.org
Classification: Unclassified
Component: Version control (show other bugs)
Version: unspecified
Hardware: Other All
: high blocker
Assignee: fd.o Admin Massive
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 39197 96181 97008
  Show dependency treegraph
 
Reported: 2016-07-21 07:37 UTC by Simon McVittie
Modified: 2016-07-25 11:01 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon McVittie 2016-07-21 07:37:38 UTC
dbus.git seems to have lost its write access for members of group dbus:

$ git push origin master
Counting objects: 6, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (6/6), done.
Writing objects: 100% (6/6), 1.72 KiB | 0 bytes/s, done.
Total 6 (delta 5), reused 0 (delta 0)
remote: error: insufficient permission for adding an object to repository database objects
remote: fatal: failed to write object
error: unpack failed: unpack-objects abnormal exit
To git+ssh://git.freedesktop.org/git/dbus/dbus
 ! [remote rejected] master -> master (unpacker error)
error: failed to push some refs to 'git+ssh://git.freedesktop.org/git/dbus/dbus'

$ ssh annarchy groups
freedesktop dbus telepathy wocky ytstenut

$ ssh annarchy getfacl /git/dbus/dbus.git
getfacl: Removing leading '/' from absolute path names
# file: git/dbus/dbus.git
# owner: desrt
# group: dbus
user::rwx
group::r-x
other::r-x
Comment 1 Simon McVittie 2016-07-21 11:48:33 UTC
Ralf reports getting the same error.
Comment 2 Ralf Habacker 2016-07-23 07:11:47 UTC
(In reply to Simon McVittie from comment #0)
> dbus.git seems to have lost its write access for members of group dbus:
 
This is still an issue and prevents pushing any commit to dbus git repo. 

> # owner: desrt
ssh rhabacker@annarchy.freedesktop.org "getent passwd | grep desrt"
desrt:x:2703:800:Ryan Lortie:/home/desrt:/bin/bash
This issue can only be fixed by Ryan Lortie or someone else with root access
Comment 3 Simon McVittie 2016-07-23 09:58:34 UTC
(In reply to Ralf Habacker from comment #2)
> This is still an issue and prevents pushing any commit to dbus git repo. 

Use the mirror at https://github.com/d-bus/dbus/tree/master for now (you'll need to rebase, there's already a reviewed dbus-launch commit from me there), and one of us can sync that branch to fd.o when we get write access back.
Comment 4 Ralf Habacker 2016-07-23 15:24:33 UTC
(In reply to Simon McVittie from comment #3)
> (In reply to Ralf Habacker from comment #2)
> > This is still an issue and prevents pushing any commit to dbus git repo. 
> 
> Use the mirror at https://github.com/d-bus/dbus/tree/master for now (you'll
> need to rebase, there's already a reviewed dbus-launch commit from me
> there), and one of us can sync that branch to fd.o when we get write access
> back.
Sorry, do not work because I do not have write access to your github dbus project. The only possible way is currently to clone https://github.com/d-bus/dbus and to create a pull request.
Comment 5 Daniel Stone 2016-07-25 10:55:31 UTC
Fixed now
Comment 6 Simon McVittie 2016-07-25 11:01:23 UTC
(In reply to Daniel Stone from comment #5)
> Fixed now

Thanks! Confirmed to work. I've synced the master and dbus-1.10 branches back from Github.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.