Bug 97037 - Parts of GUI blinking with fullscreen video playback on 2nd screen
Summary: Parts of GUI blinking with fullscreen video playback on 2nd screen
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: high major
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-22 01:02 UTC by Konstantin Svist
Modified: 2016-07-26 22:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Svist 2016-07-22 01:02:54 UTC
kernel: 4.6.4-201.fc23.x86_64
git commit: 4eaab17aec8ea66428087065901324f56df9020e

I'm seeing parts of the GUI blink between updated buffer and some semi-corrupted earlier buffer at times. This usually happens on youtube fullscreen video playback (flash/html5? in Firefox), but sometimes seen without fullscreen video (just now happened in Xfce terminal on "git log" command -- was flipping between mostly-blank and screenfull of log for a few seconds).


dual video hardware, bumblebee (usually keep nvidia card disabled):

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
	Subsystem: CLEVO/KAPOK Computer Device [1558:5281]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 35
	Region 0: Memory at f7400000 (64-bit, non-prefetchable) [size=4M]
	Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at f000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee00018  Data: 0000
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [a4] PCI Advanced Features
		AFCap: TP+ FLR+
		AFCtrl: FLR-
		AFStatus: TP-
	Kernel driver in use: i915
	Kernel modules: i915


01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104M [GeForce GTX 870M] [10de:1199] (rev ff) (prog-if ff)
	!!! Unknown header type 7f
	Kernel modules: nouveau, nvidia



Another bug related to fullscreen video (no idea if related/same): at one bootup, horizontal lines showed up as noise at some [random?] locations in video clip during playback. At another bootup, no problem..


Updating to today's commit, might make a difference..
Comment 1 Konstantin Svist 2016-07-26 00:24:24 UTC
update didn't make a difference, still getting blinking between 2 states

Upgraded to Fedora 24, the fullscreen video corruption is gone -- so was unrelated
Comment 2 Konstantin Svist 2016-07-26 22:25:47 UTC
This is affecting a lot more than I thought earlier -- I often get this effect when a window is maximized on one screen (the other screen starts blinking.. whole or part). It's very disruptive to normal work (e.g. full screen browser in one screen & terminal window in another)
If there's any workaround I can apply, please let me know asap!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.