Bug 97066 - Blank screen when starting KMS on a GTX970 for kernel 4.6 series
Summary: Blank screen when starting KMS on a GTX970 for kernel 4.6 series
Status: RESOLVED DUPLICATE of bug 94990
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-24 17:16 UTC by smmilut
Modified: 2016-08-24 21:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
full dmesg when experiencing the bug, and with drm.debug=14 log_buf_len=16M (85.73 KB, text/plain)
2016-07-24 17:16 UTC, smmilut
no flags Details
lspci -v (6.13 KB, text/plain)
2016-07-24 17:18 UTC, smmilut
no flags Details
kernel config in 4.6.4 (176.64 KB, text/plain)
2016-07-24 17:19 UTC, smmilut
no flags Details
Xorg.0.log file when trying to start Xorg after selecting nouveau.noaccel=1 nouveau.nofbaccel=1 (7.26 KB, text/plain)
2016-07-24 18:24 UTC, smmilut
no flags Details
dmesg when trying to start Xorg after selecting nouveau.noaccel=1 nouveau.nofbaccel=1 (78.71 KB, text/plain)
2016-07-24 18:25 UTC, smmilut
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description smmilut 2016-07-24 17:16:53 UTC
Created attachment 125292 [details]
full dmesg when experiencing the bug, and with drm.debug=14 log_buf_len=16M

Hello,

Since i upgraded my kernel from 4.5.4 to 4.6.3, the screen goes "blank" when entering KMS, instead of giving the high resolution tty.
By "blank", i mean it has a uniform colour : during some boots it's pure red, other boots it's pure magenta, and sometimes pure white.
The system is functional and i am able to ssh remotely into the machine.

My setup :
- single 2560x1440 monitor
- NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1) (prog-if 00 [VGA controller])
- both DVI and DisplayPort ports exhibit the issue
- Arch Linux

If i disable modesetting, i am able to see an image on the screen (low resolution tty) and login to the system (no Xorg though, as expected).

I found bug 94990 which seems similar, although the symptoms are a bit different (his monitor goes to sleep, mine remains ON and monochromatic). Also, i have a similar motherboard (Z97-A).

So i tried one advice i saw there : booting with nouveau.config=NvForcePost=1 got me no signal instead of a uniform colour.

Sorry if i'm actually posting a duplicate, i'm not very experienced with this :) I'll try provide more info if i can.
Comment 1 smmilut 2016-07-24 17:18:05 UTC
Created attachment 125293 [details]
lspci -v
Comment 2 smmilut 2016-07-24 17:19:11 UTC
Created attachment 125294 [details]
kernel config in 4.6.4
Comment 3 Ilia Mirkin 2016-07-24 17:20:46 UTC
Observation for Alexandre: This GTX 970 also has 4GB of VRAM.

For the OP: you can probably restore your original functionality by booting with

nouveau.noaccel=1 nouveau.nofbaccel=1

or alternatively by moving the secboot firmware out of the way (/lib/firmware/nvidia/gm204) temporarily.
Comment 4 smmilut 2016-07-24 18:21:12 UTC
Indeed, and the exact commercial model name is "Msi GTX970 Gaming 4G".

When booting with :
nouveau.noaccel=1 nouveau.nofbaccel=1
i have a normal image on screen when entering KMS, and get my normal high resolution tty.
However, i am unable to start Xorg.
(attached are the corresponding Xorg.log and dmesg)

When you say "moving the secboot firmware out of the way", does it mean i just have to temporarily rename the directory "/lib/firmware/nvidia/gm204" ?
Comment 5 smmilut 2016-07-24 18:24:44 UTC
Created attachment 125295 [details]
Xorg.0.log file when trying to start Xorg after selecting nouveau.noaccel=1 nouveau.nofbaccel=1
Comment 6 smmilut 2016-07-24 18:25:17 UTC
Created attachment 125296 [details]
dmesg when trying to start Xorg after selecting nouveau.noaccel=1 nouveau.nofbaccel=1
Comment 7 Ilia Mirkin 2016-07-24 18:30:39 UTC
(In reply to smmilut from comment #5)
> Created attachment 125295 [details]
> Xorg.0.log file when trying to start Xorg after selecting nouveau.noaccel=1
> nouveau.nofbaccel=1

Fun. Looks like Xorg properly falls back to modesetting (yay), but then just hangs there when trying to initialize glamor. No idea why.

I think there's some Xorg config option you can provide to avoid loading glamor. Not sure what it is.
Comment 8 Ilia Mirkin 2016-08-24 21:22:01 UTC

*** This bug has been marked as a duplicate of bug 94990 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.