Bug 97079 - [SKL] GPU HANG: ecode 9:0:0x84dffff8, in Xorg [2693]
Summary: [SKL] GPU HANG: ecode 9:0:0x84dffff8, in Xorg [2693]
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-25 16:29 UTC by Thomas Backlund
Modified: 2017-02-10 22:38 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features: GPU hang


Attachments
crash dump: /sys/class/drm/card0/error (22.54 KB, application/x-bzip)
2016-07-25 16:29 UTC, Thomas Backlund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Backlund 2016-07-25 16:29:25 UTC
Created attachment 125318 [details]
crash dump: /sys/class/drm/card0/error

dmesg:

22168.027941] [drm] stuck on render ring
[22168.029016] [drm] GPU HANG: ecode 9:0:0x84dffff8, in Xorg [2693], reason: Engine(s) hung, action: reset
[22168.029022] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[22168.029025] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[22168.029029] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[22168.029033] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[22168.029037] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[22168.030991] drm/i915: Resetting chip after gpu hang
[22170.024094] [drm] RC6 on


System: ASUSTeK UX303UA
CPU: Dual core Intel Core i5-6200U
Graphics:  Card: Intel HD Graphics 520

Distro; Mageia 6 / Cauldron x86_64
kernel 4.7.0
xorg 1.18.4
mesa 12.0.1
libdrm 2.4.70
xf86-video-intel-2.99.917-git, topmost commit:

commit 26f8ab5429a554801641415f0ab3b2d68cea1d00
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Mon Jul 4 10:11:50 2016 +0100

sna: Restore local damage processing for TearFree/DRI2/swcursor early
Comment 1 yann 2016-08-03 14:24:22 UTC
Assigning to Mesa product (please let me know if I am mistaken with this GPU Hang).

From this error dump, hung is happening in batch with active head at 0xff01593c, with  0x7b000005 as IPEHR

0xff01591c:      0x78090005: 3DSTATE_VERTEX_ELEMENTS
0xff015920:      0x02000000:    buffer 0: invalid, type 0x0000, src offset 0x0000 bytes
0xff015924:      0x22220000:    (0.0, 0.0, 0.0, 0.0), dst offset 0x00 bytes
0xff015928:      0x02f60000:    buffer 0: invalid, type 0x00f6, src offset 0x0000 bytes
0xff01592c:      0x11230000:    (X, Y, 0.0, 1.0), dst offset 0x00 bytes
0xff015930:      0x02f60004:    buffer 0: invalid, type 0x00f6, src offset 0x0004 bytes
0xff015934:      0x11230000:    (X, Y, 0.0, 1.0), dst offset 0x00 bytes
Bad length 7 in (null), expected 6-6
0xff015938:      0x7b000005: 3DPRIMITIVE: fail sequential
0xff01593c:      0x00000000:    vertex count
0xff015940:      0x00000003:    start vertex
0xff015944:      0x0000015a:    instance count
0xff015948:      0x00000001:    start instance
0xff01594c:      0x00000000:    index bias
0xff015950:      0x00000000: MI_NOOP
Comment 2 yann 2016-08-03 14:25:43 UTC
I set to "unspecified" version since this is 12.0.1 which is not available in the version picking list
Comment 3 Matt Turner 2016-11-04 00:21:25 UTC
Please test a new version of Mesa 13 and mark as REOPENED if you can reproduce and RESOLVED/* if you cannot reproduce.
Comment 4 Annie 2017-02-10 22:38:35 UTC
Dear Reporter,

This Mesa bug has been in the "NEEDINFO" status for over 60 days. I am closing this bug based on lack of response but feel free to reopen if resolution is still needed. Please ensure you're supplying the correct information as requested.

Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.