Bug 97081 - Condensed variants of DejaVu Sans and Serif no longer work
Summary: Condensed variants of DejaVu Sans and Serif no longer work
Status: RESOLVED FIXED
Alias: None
Product: DejaVu
Classification: Unclassified
Component: Sans (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Deja Vu bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-25 18:09 UTC by Jussi Hukkanen
Modified: 2016-07-30 11:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jussi Hukkanen 2016-07-25 18:09:06 UTC
Last week my Debian system upgraded the DejaVu font packages from version 2.35-1 to 2.36-1. Afterwards I noticed that in LibreOffice, any text using Dejavu Sans Condensed had become invisible, as if it was white text on a white background (which it wasn't). The same applies to Dejavu Serif Condensed. All other fonts are working fine.

This might be a bug in LibreOffice, which was upgraded at the same time. However, I don't think that's the case, because I tried to type some text in GIMP using both DejaVu Sans (Book) and DejaVu Sans Condensed, and the latter didn't seem condensed at all. Instead, both fonts looked identical. I also found out that in Mousepad's font selector window, not only Sans Condensed, but also its Oblique, Bold and Bold Oblique variants, appeared identical to Sans Book.

Steps to reproduce:
1. Start LibreOffice Writer or Calc.
2. Select Dejavu Sans Condensed or Serif Condensed. Type some text.
3. What happens is that the cursor moves on the page, but no text appears.

I'll be happy to provide more information as needed.

OS:
Debian stretch, Linux 4.6.0-1-amd64

Packages:
fonts-dejavu-core 2.36-1
fonts-dejavu-extra 2.36-1
libreoffice 1:5.1.5~rc1-1
Comment 1 Ben Laenen 2016-07-25 23:26:52 UTC
Thanks for reporting, it looks like there has been an error in the upload process. The source files of the condensed fonts that were released have for some reason empty glyphs in them.

All the ttf files that you can find on http://dejavu-fonts.org/wiki/Download have the correct files, but since Debian also makes their own ttf files from source, the files they've created also have the error.

We'll need to investigate what exactly went wrong during the release, and probably make a new release shortly to fix this.

I guess you can temporarily work around it by installing the released ttf files from 2.36 and replacing them manually, or installing them as a user instead of system-wide, so they're used instead, if that's not too much of a problem.
Comment 2 Jussi Hukkanen 2016-07-26 11:14:33 UTC
Thank you. Downloading the 2.36 files and installing them locally fixed the issue for now. Glad I could help!
Comment 3 Ben Laenen 2016-07-30 11:05:05 UTC
A new 2.37 release has been made. When the distros update their packages, you should be able to use the fonts from you distro.

Thanks again for the report!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.