Bug 97131 - GPU hang leading to system hang
Summary: GPU hang leading to system hang
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-29 14:20 UTC by marius
Modified: 2016-08-16 12:20 UTC (History)
1 user (show)

See Also:
i915 platform: HSW
i915 features: GPU hang


Attachments
Error log after suspend (26.45 KB, text/plain)
2016-07-29 14:21 UTC, marius
Details
/sys/class/drm/card0/error (3.02 MB, text/plain)
2016-08-13 10:50 UTC, marius
Details
Second example from journalctl (8.47 KB, text/plain)
2016-08-13 15:08 UTC, marius
Details
Second example from /sys/class/drm/card0/error (25 bytes, text/plain)
2016-08-13 15:10 UTC, marius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marius 2016-07-29 14:20:52 UTC
I'm regularly having troubles with GPU hangs (at least it says so in the logs - I attached one of them). This one happened after returning from suspend. I'm not quite sure which versions are important, I'm running mesa 12.0.1-2, libdrm 2.4.70-1 and xf86-video-intel 1:2.99.917+676+g26f8ab5-1 on a current&updated archlinux. Do you need any more information?
Comment 1 marius 2016-07-29 14:21:22 UTC
Created attachment 125415 [details]
Error log after suspend
Comment 2 marius 2016-07-29 14:25:51 UTC
The machine is a Thinkpad x240 with a Intel Core i5-4300U
Comment 3 Chris Wilson 2016-07-29 15:41:26 UTC
Hopefully /sys/class/drm/card0/error has more clues. Please attach following the hang upon resume (use cat, and grab it before rebooting).
Comment 4 marius 2016-08-13 10:50:50 UTC
Created attachment 125764 [details]
/sys/class/drm/card0/error
Comment 5 marius 2016-08-13 15:08:51 UTC
Created attachment 125769 [details]
Second example from journalctl

It just happened again, here's another exert from journalctl. Unfortunately I couldn't get /sys/class/drm/card0/error again because the whole system died on me. Hope this helps
Comment 6 marius 2016-08-13 15:10:20 UTC
Created attachment 125770 [details]
Second example from /sys/class/drm/card0/error

... I'm attaching it anyways - maybe it helps even after a reboot?
Comment 7 marius 2016-08-16 12:18:31 UTC
Can I in any way help by providing more information and speed up the progress of a fix? It's really bugging me, I can't use my laptop like this and it neither works properly with the LTS nor with the current linux kernel.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.