Bug 97169 - xmgrace graphical issues with Intel gen4
Summary: xmgrace graphical issues with Intel gen4
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-01 17:18 UTC by Timo Aaltonen
Modified: 2016-12-15 06:58 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Aaltonen 2016-08-01 17:18:09 UTC
downstream bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=832794

After installing xmgrace and running it with modesetting on Intel gen4 gpu..

"..a blank plot is shown by default. The background should be white, but,
instead, a matrix of equally-spaced black dots is displayed on the
background.

Select Plot appearance... from the Plot menu and change the Color
in the Page background section. For instance, choose Orange as
Page background Color and check Fill.
Click on the Accept button.

The background should become uniformly orange. Instead, the background
stays transparent (white with the regular black dot grid)."

xorg-server 1.18.4
mesa 12.0.1
Comment 1 Martin Peres 2016-08-01 17:37:33 UTC
Thanks for reporting the issue. FYI, it works on my hsw-gt2.
Comment 2 Ben Widawsky 2016-08-01 19:04:26 UTC
@timo, is this just gen4? Could you try something else pre-sandybridge?
Comment 3 Timo Aaltonen 2016-08-01 19:18:14 UTC
so far just gen4, and I don't have ironlake :/
Comment 4 Timo Aaltonen 2016-08-01 19:55:35 UTC
verified that sandybridge is fine
Comment 5 Ben Widawsky 2016-08-02 05:08:02 UTC
(In reply to Timo Aaltonen from comment #4)
> verified that sandybridge is fine

Was mostly curious if it's something old without LLC (or new without LLC)
Comment 6 Timo Aaltonen 2016-08-02 07:42:14 UTC
baytrail is fine as well
Comment 7 Kenneth Graunke 2016-08-03 03:19:16 UTC
Note that Gen4-5 don't expose GLSL 1.30, so many of Glamor's integer code paths will be disabled (as GLSL 1.10-1.20 allow integers to be represented as floats, so e.g. bitfield tricks may not work).

Gen4-5 of course use real integers, so we really ought to find a way to get Glamor using integer paths properly.  I believe those paths are faster, as well as better tested.  Ian has a couple of GL_MESA_* extensions in progress we might be able to leverage...

(I don't know that this is actually the problem, it's just a difference between Gen4-5 and Gen6+ that could be relevant.  We'll have to look into it properly.)
Comment 8 Eric Anholt 2016-12-15 05:56:11 UTC
Tried to reproduce under Xephyr -glamor with server master and Mesa master with MESA_GLSL_VERSION_OVERRIDE=120 MESA_GL_VERSION_OVERRIDE=2.1 on skl, didn't see anything wrong in the default window.
Comment 9 Paul Wise 2016-12-15 06:11:26 UTC
I'm on Ironlake and modesetting running Debian stretch. I also see the black dots displayed on the blank plot.
Comment 10 Paul Wise 2016-12-15 06:53:36 UTC
I note both the dots and the background issue is fixed by xorg-server 1.19.0.
Comment 11 Timo Aaltonen 2016-12-15 06:58:04 UTC
looks like this is fixed in xserver 1.19 with

commit c9b8ce73927a43ed82b267d1c1985445f24827cc
Author: Mark Yao <mark.yao@rock-chips.com>
Date:   Fri Sep 30 16:42:35 2016 +0800

    glamor: spans: fixup wrong count on glDrawArrays


I haven't verified it myself, but believe the other reports, so closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.