Bug 97178 - [drm:pwm_setup_backlight [i915]] *ERROR* Failed to own the pwm chip
Summary: [drm:pwm_setup_backlight [i915]] *ERROR* Failed to own the pwm chip
Status: CLOSED DUPLICATE of bug 96571
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-02 08:27 UTC by Filipp Andjelo
Modified: 2017-07-24 22:40 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: display/backlight


Attachments
dmesg, see from 8.894590 (107.15 KB, text/x-log)
2016-08-02 08:27 UTC, Filipp Andjelo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filipp Andjelo 2016-08-02 08:27:04 UTC
Created attachment 125473 [details]
dmesg, see from 8.894590

Cherry Trail tablet Chuwi HiBook
Comment 1 yann 2016-08-02 09:57:56 UTC
I guess that following change in drivers/gpu/drm/i915/intel_panel.c, line 1748 on top of kernel 4.6.x (check https://lists.freedesktop.org/archives/intel-gfx/2016-February/087151.html)
-		if (dev_priv->vbt.has_mipi) {
+		if (connector->base.connector_type == DRM_MODE_CONNECTOR_DSI) {

should solve your issue.

FYI this is not part of 4.6.x kernel but part of 4.7 or our drm-intel-nightly. So either you upgrade to a more recent kernel or apply that change
Comment 2 Jani Nikula 2016-08-02 10:58:34 UTC
(In reply to yann from comment #1)
> I guess that following change in drivers/gpu/drm/i915/intel_panel.c, line
> 1748 on top of kernel 4.6.x (check
> https://lists.freedesktop.org/archives/intel-gfx/2016-February/087151.html)
> -		if (dev_priv->vbt.has_mipi) {
> +		if (connector->base.connector_type == DRM_MODE_CONNECTOR_DSI) {
> 
> should solve your issue.

I don't think that should make a difference. More likely a dupe of bug 96571.

*** This bug has been marked as a duplicate of bug 96571 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.