Bug 97187 - [ILK] [BAT] kms_cursor_legacy/basic-cursor-vs-flip-legacy fails to complete expected number of updates
Summary: [ILK] [BAT] kms_cursor_legacy/basic-cursor-vs-flip-legacy fails to complete e...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: highest blocker
Assignee: cprigent
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-02 13:11 UTC by Ville Syrjala
Modified: 2016-09-30 09:07 UTC (History)
1 user (show)

See Also:
i915 platform: ILK
i915 features: display/atomic


Attachments
KBL_basic-cursor-vs-flip-legacy_output (3.17 KB, text/plain)
2016-08-04 16:49 UTC, cprigent
no flags Details
KBL_basic-cursor-vs-flip-legacy_kern.log (161.78 KB, text/plain)
2016-08-04 16:50 UTC, cprigent
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ville Syrjala 2016-08-02 13:11:34 UTC
(kms_cursor_legacy:11048) DEBUG: Test requirement passed: target > 1
(kms_cursor_legacy:11048) DEBUG: Using a target of 256 cursor updates per half-vblank
(kms_cursor_legacy:11048) CRITICAL: Test assertion failure function basic_cursor_vs_flip, file kms_cursor_legacy.c:678:
(kms_cursor_legacy:11048) CRITICAL: Failed assertion: shared[0] > 60*target
(kms_cursor_legacy:11048) CRITICAL: completed 118 cursor updated in a period of 60 flips, we expect to complete approximately 30720 updateds, with the threshold set at 15360
Comment 1 cprigent 2016-08-04 16:49:10 UTC
Created attachment 125538 [details]
KBL_basic-cursor-vs-flip-legacy_output
Comment 2 cprigent 2016-08-04 16:50:07 UTC
Created attachment 125539 [details]
KBL_basic-cursor-vs-flip-legacy_kern.log

Same on KBL-U

Platform: KABY LAKE-U
CPU : Intel(R) Core(TM) @ 2.60GHz
MCP : KBL-U G0 2+2
QDF : QYQ8
Chipset PCH: SPT-LP C1
CRB : KABY LAKE U DDR3L RVP7 CRB FAB1

Software
BIOS: 38_07 KBLSE2R1.R00.X038.P07.1606200632 from https://ubit-artifactory-ba.intel.com/artifactory/simple/one-windows-local/Submissions/ifwi/KBL_PURPLE_IFWI_2016_WW26_1_00_HR'16/IFWI-KBL_PURPLE_IFWI_2016_WW26_1_00_HR'16-R.7z
ME FW: 11.5.0.1058
EC FW: 1.19
Ksc (EC FW): 1.20
Linux distribution: Ubuntu 16.04 64 bits
Kernel: 4.7.0 6f87e85 from http://cgit.freedesktop.org/drm-intel/
   commit 6f87e85fa302ffdb4cb9f4cd712691165923c7a2
 Author: Chris Wilson <chris@chris-wilson.co.uk>
  Date:   Mon Aug 1 15:53:41 2016 +0100
  drm-intel-nightly: 2016y-08m-01d-14h-53m-17s UTC integration manifest
drm: libdrm-2.4.70 f19cd3a from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-11.2.2 3a9f628from git://anongit.freedesktop.org/mesa/mesa
cairo: 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xserver: xorg-server-1.18.0-502 c833c08 from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel: 2.99.917-688 49daf5d from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva: libva-1.7.0-40 f7e2263 from git://git.freedesktop.org/git/vaapi/libva
vaapi-intel-driver: 1.7.0-64 1cd6795 from git://git.freedesktop.org/git/vaapi/intel-driver
GuC 9.14 from http://rdvivi-hillsboro.jf.intel.com/firmware/kbl_guc_ver9_14.tar.bz2 
DMC 1.01 from: https://01.org/linuxgraphics/downloads/kabylake-dmc-1.01 
Intel-Gpu-Tools 1.15-188 53b4dfd from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git
Comment 3 cprigent 2016-09-01 10:57:19 UTC
Not reproduced on KBL.

Platform: KABY LAKE-U
Processor : Genuine Intel(R) CPU 0000 @ 1.80GHz (cpu family: 6, model: 142, stepping: 9)
MCP : KBL-U J0 2+3e
QDF : QL9J
PCH: PCH-LP C1
CRB : KABY LAKE U DDR3L RVP7
Rework: O-16

Software
BIOS: 45.1 3KBLSE2R1.R00.X045.P01.1606291634 from https://ubit-artifactory-ba.intel.com/artifactory/owr-repos/Submissions/ifwi/KBL_ORANGE_IFWI_2016_WW27_3_03_SR'17/
ME FW: 11.6.0.1065
EC FW: 1.24
KSC: 1.24
Linux distribution: Ubuntu 16.04 64 bits
Kernel: 4.8.0-rc4 f4f46e5 from http://cgit.freedesktop.org/drm-intel/
  commit f4f46e5544894b2198cdfd5a226ee587d9834cc4}}
  Author: Daniel Vetter <daniel.vetter@ffwll.ch>
  Date: Mon Aug 29 16:09:42 2016 +0200
  drm-intel-nightly: 2016y-08m-29d-14h-09m-23s UTC integration manifest
ibdrm-2.4.70-2 b214b05 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-11.2.2 3a9f628from git://anongit.freedesktop.org/mesa/mesa
cairo 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xorg-server-1.18.0-535 25e4f9e from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel 2.99.917-698 71d3273 from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva-1.7.0-47 2ebf897 from git://git.freedesktop.org/git/vaapi/libva 
vaapi-intel-driver: 1.7.0-95 1817bee from git://git.freedesktop.org/git/vaapi/intel-driver
Intel-Gpu-Tools 1.15 572a770 from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git

I can't check on ILK.
Comment 4 Jani Saarinen 2016-09-07 07:30:40 UTC
Not seen on KBL lately on CI. But we should check BDW and BSW.
But this bug is for KBL. Should we make own for others or use this in general?
Comment 5 Jani Saarinen 2016-09-07 07:31:42 UTC
(In reply to jani.saarinen from comment #4)
> Not seen on KBL lately on CI. But we should check BDW and BSW.
> But this bug is for KBL. Should we make own for others or use this in
> general?

Sorry, I meant this bug is made for ILK.
Comment 6 Jari Tahvanainen 2016-09-08 10:06:32 UTC
On ILK this failure has not been triggered by basic-cursor-vs-flip-legacy on CI testing after CI_DRM_1564. There has been different failure on CI_DRM_1591/fi-bsw-n3050 on 26-Aug-2016 and CI_DRM_1583/fi-hsw-4770k on 24-Aug-2016. For these one should create new bug if problem persist.

I propose this bug to be marked as fixed+worksforme. Please comment if you disagree.
Comment 7 Jani Saarinen 2016-09-08 15:51:50 UTC
Ville, Jani N, do you agree?
Comment 8 Jani Nikula 2016-09-09 07:16:21 UTC
Ack.
Comment 9 yann 2016-09-09 07:25:53 UTC
(In reply to Jani Saarinen from comment #7)
> Ville, Jani N, do you agree?

Ville, since you are bug reporter do you ack or nack?
Comment 10 Jari Tahvanainen 2016-09-30 09:06:58 UTC
Ack got from Ville too through IRC "presumably fixed by the mutex fariness stuff". Resolved+Fixed - Verified (CI Testing) - Closed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.