Bug 97206 - [BXT-P] Blank screen while using Kwin on Ubuntu
Summary: [BXT-P] Blank screen while using Kwin on Ubuntu
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: All Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-04 17:39 UTC by Luis Botello
Modified: 2018-04-05 14:46 UTC (History)
1 user (show)

See Also:
i915 platform: BXT
i915 features: display/eDP


Attachments
dmesg.log (110.84 KB, text/plain)
2016-08-04 17:39 UTC, Luis Botello
no flags Details
Xorg.log (40.43 KB, text/plain)
2016-08-04 17:40 UTC, Luis Botello
no flags Details
xsession-errors (18.36 KB, text/plain)
2017-03-31 23:49 UTC, Luis Botello
no flags Details
new dmesg BSW (100.11 KB, text/plain)
2017-10-02 17:00 UTC, Armando Antonio
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Botello 2016-08-04 17:39:48 UTC
Created attachment 125540 [details]
dmesg.log

Description:
-----------------------------
Display goes to blank screen while K-win environment is launched.

System enviroment
------------------------------

Platform: SKL-U
OS: Ubuntu 16.04
Architecture: 64 / 32 bits
Kernel = 4.4.0-21-generic
Mesa = 11.2.2
xf86-video-intel = 2.99.917 
libdrm = 2.4.68
libva = 1.7.1
vaapi-intel-driver = 1.7.1
Cairo = 1.15.2 
Xorg Xserver = 1.18.3

Attachemnts
-------------------------------
dmesg.log
Xorg.log
Comment 1 Luis Botello 2016-08-04 17:40:11 UTC
Created attachment 125541 [details]
Xorg.log
Comment 2 maria guadalupe 2016-11-16 19:42:51 UTC
The problem persists with following configuration over BDW ubuntu 32bits

xf86-video-intel : xorg-x11-drv-intel-2.99.917-24.20160712.fc24.i686
mesa : mesa-libgbm-12.0.3-2.fc24.i686
cairo : cairo-1.15.2-24.intel20162.i686
drm : libdrm-2.4.71-2.fc24.i686
libva : libva-intel-driver 1.7.2-24.intel20162.i686
Comment 3 Jari Tahvanainen 2017-03-27 11:03:10 UTC
Luis et.al. - is the problem still valid for the latest setup(s) on SKL (and other environments)?
Comment 4 Luis Botello 2017-03-31 23:46:21 UTC
This issue is still seen with the following config:

======================================
             Software
======================================
kernel version            : 4.11.0-rc4-drm-tip-ww14-commit-19ceec7+
architecture              : x86_64
os version                : Ubuntu 16.10
os codename               : yakkety
[sudo] password for gfx: kernel driver             : i915
bios revision             : 5.6
ksc                       : 13.0

======================================
        Graphic drivers
======================================
mesa                      : 17.0.1 (git-8fee1d3
modesetting               : modesetting_drv.so
xorg-xserver              : 1.18.4
libdrm                    : 2.4.75
cairo                     : 1.15.4
xserver                   : X.Org X Server 1.19.2
intel-gpu-tools (tag)     : intel-gpu-tools-1.18
intel-gpu-tools (commit)  : bb97a05

======================================
             Hardware
======================================
motherboard model         : NUC6CAYS
motherboard id            : NUC6CAYB
form factor               : Desktop
manufacturer              : Intelcorporation
cpu family                : Celeron
cpu family id             : 6
cpu information           : Intel(R) Celeron(R) CPU J3455 @ 1.50GHz
gpu card                  : Intel Corporation Device 5a85 (rev 0b) (prog-if 00 [VGA controller])
Comment 5 Luis Botello 2017-03-31 23:49:33 UTC
Adding xsession-errors
Comment 6 Luis Botello 2017-03-31 23:49:48 UTC
Created attachment 130630 [details]
xsession-errors
Comment 7 Elizabeth 2017-08-16 22:32:58 UTC
Hello, 
This issue couldn't be replicated on SKL with the following configuration, so I'll remove SKL from summary and feature. Thank you.
======================================
             Software
======================================
kernel version              : 4.10.0-32-generic
hostname                    : gfx-desktop
architecture                : i686
os version                  : Ubuntu 17.04
os codename                 : zesty
kernel driver               : i915
bios revision               : 5.6
bios release date           : 09/29/2016
hardware acceleration       : disabled
swap partition              : enabled on (/dev/sda1) 
======================================
        Graphic drivers
======================================
mesa                        : 17.0.7
Xorg			    : 1.19.3
libdrm                      : 2.4.76
libva                       : 1.8.3
vaapi (intel-driver)        : 1.8.3
intel-gpu-tools             : 1.19-1 
======================================
             Hardware
======================================
platform                   : Skylake Canyon
motherboard id             : NUC6i7KYB
form factor                : Desktop
cpu family                 : Core i7
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i7-6770HQ CPU @ 2.60GHz
gpu card                   : Intel Corporation Iris Pro Graphics 580 (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 31.56 GB
max memory ram             : 32 GB
display resolution         : 3840x1200
cpu thread                 : 8
cpu core                   : 4 
cpu model                  : 94
cpu stepping               : 3
socket                     : Other
signature                  : Type 0, Family 6, Model 94, Stepping 3
hard drive                 : 223GiB (240GB)
current cd clock frequency : 337500 kHz
maximum cd clock frequency : 675000 kHz
displays connected         : DP-3 
======================================
             Firmware
======================================
dmc fw loaded             : yes
dmc version               : 1.26
guc fw loaded             : NONE
guc version wanted        : 6.1
guc version found         : 0.0 

Note: Adding tag into "Whiteboard" field - ReadyForDev
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 8 Armando Antonio 2017-10-02 17:00:26 UTC
Created attachment 134625 [details]
new dmesg BSW
Comment 9 Armando Antonio 2017-10-02 17:00:40 UTC
Hello this issue still happen on BSW, attached new dmesg log

Regards
Comment 10 Elizabeth 2018-03-23 22:07:46 UTC
On BSW with ubuntu 17.10 and KDE 5.10.5 I can't reproduce anymore this issue. So removing.

kernel version             : 4.16.0-rc6-commit-4db112a+ x86_64
os version                 : Ubuntu 17.10 artful
kernel driver              : i915
libdrm                     : 2.4.91
libva                      : 1.8.3-2
vaapi (intel-driver)       : 1.8.3
cpu information            : Intel(R) Pentium(R) CPU  N3700  @ 1.60GHz
displays connected         : eDP-1
Comment 11 Jani Saarinen 2018-03-29 07:10:18 UTC
First of all. Sorry about spam.
This is mass update for our bugs. 

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.
Comment 12 Elizabeth 2018-04-05 14:46:49 UTC
On BXT with ubuntu 17.10, latest stable from kernel.org and KDE 5.10.5 I can't reproduce this issue anymore. Closing.

======================================
             Software
======================================
kernel version              : 4.16.0
hostname                    : gfx-desktop
architecture                : x86_64
os version                  : Ubuntu 17.10
os codename                 : artful
kernel driver               : i915
bios revision               : 5.6
bios release date           : 08/25/2017
ksc                         : 13.0
hardware acceleration       : disabled
swap partition              : enabled on (/dev/sda2)

======================================
             Hardware
======================================
motherboard model          : NUC6CAYS
motherboard id             : NUC6CAYB
form factor                : Desktop
manufacturer               : Intelcorporation
cpu family                 : Celeron
cpu family id              : 6
cpu information            : Intel(R) Celeron(R) CPU J3455 @ 1.50GHz
gpu card                   : Intel Corporation Device 5a85 (rev 0b) (prog-if 00 [VGA controller])
memory ram                 : 7.64 GB
max memory ram             : 32 GB
display resolution         : 5440x1080
cpu thread                 : 4
cpu core                   : 4
cpu model                  : 92
cpu stepping               : 9
socket                     : Other
signature                  : Type 0, Family 6, Model 92, Stepping 9
hard drive                 : 74GiB (80GB)
current cd clock frequency : 288000 kHz
maximum cd clock frequency : 624000 kHz
displays connected         : DP-1

======================================
             Firmware
======================================
dmc fw loaded             : yes
dmc version               : 1.7
guc fw loaded             : fetch NONE, load NONE
guc version wanted        : wanted 9.29, found 0.0
guc version found         : wanted 9.29, found 0.0


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.