Bug 97247 - [SNB] GPU HANG: ecode 6:0:0x86fafffa, in Xorg [6051], reason: Ring hung, action: reset
Summary: [SNB] GPU HANG: ecode 6:0:0x86fafffa, in Xorg [6051], reason: Ring hung, acti...
Status: RESOLVED WONTFIX
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-08 18:26 UTC by Francois Marier
Modified: 2016-08-09 05:37 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
gpu crash dump (2.19 MB, text/plain)
2016-08-08 18:26 UTC, Francois Marier
Details
Xorg log file (30.83 KB, text/x-log)
2016-08-08 21:14 UTC, Francois Marier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Marier 2016-08-08 18:26:12 UTC
Created attachment 125604 [details]
gpu crash dump

I got saw the following error message in my logs:

Aug  8 10:29:24 akranes kernel: [59807.067411] [drm] stuck on render ring
Aug  8 10:29:24 akranes kernel: [59807.070064] [drm] GPU HANG: ecode 6:0:0x86fafffa, in Xorg [6051], reason: Ring hung, action: reset
Aug  8 10:29:24 akranes kernel: [59807.070073] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Aug  8 10:29:24 akranes kernel: [59807.070074] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Aug  8 10:29:24 akranes kernel: [59807.070076] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel
issue.
Aug  8 10:29:24 akranes kernel: [59807.070077] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Aug  8 10:29:24 akranes kernel: [59807.070078] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Aug  8 10:29:24 akranes kernel: [59807.071836] drm/i915: Resetting chip after gpu hang


Attached is the gpu crash dump from /sys/class/drm/card0/error.
Comment 1 Matt Turner 2016-08-08 18:53:00 UTC
Was it a one-time occurrence, or can you reproduce it somehow?

What hardware do you have? The output of "lspci | grep VGA" is likely sufficient.

Are you using the -modesetting driver or xf86-video-intel?

What version of Mesa do you have?
Comment 2 Francois Marier 2016-08-08 21:14:15 UTC
Created attachment 125611 [details]
Xorg log file

(In reply to Matt Turner from comment #1)
> Was it a one-time occurrence, or can you reproduce it somehow?

It was a one-time occurrence so far. I have not tried rebooting my machine to see if it happens at every boot.

> What hardware do you have? The output of "lspci | grep VGA" is likely
> sufficient.

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

> Are you using the -modesetting driver or xf86-video-intel?

I have this package installed:

xserver-xorg-video-intel/unstable,unstable,now 2:2.99.917+git20160706-1 amd64

but my Xorg.1.log shows this:

[   198.884] (==) Matched modesetting as autoconfigured driver 0
[   198.884] (==) Matched fbdev as autoconfigured driver 1
[   198.884] (==) Matched vesa as autoconfigured driver 2
[   198.884] (==) Assigned the driver to the xf86ConfigLayout
[   198.884] (II) LoadModule: "modesetting"
[   198.885] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   198.885] (II) Module modesetting: vendor="X.Org Foundation"
[   198.885]    compiled for 1.18.4, module version = 1.18.4
[   198.885]    Module class: X.Org Video Driver
[   198.885]    ABI class: X.Org Video Driver, version 20.0

I've attached the complete Xorg.1.log file in case I extracted the wrong part.

> What version of Mesa do you have?

Most of the Mesa packages installed on my system are for version 10.3.2 but I also have these:

ii  mesa-utils                   8.2.0-1
ii  libglu1-mesa:amd64           9.0.0-2
ii  libglu1-mesa:i386            9.0.0-2
ii  libglu1-mesa-dev             9.0.0-2
Comment 3 Matt Turner 2016-08-09 00:46:49 UTC
Thanks for the info. To summarize: Sandybridge, modesetting driver, mesa-10.3.2.

I know Debian recently switched to using the modesetting driver by default, so if you have that I'm surprised that the version of Mesa you have is as old as it is. I would *strongly* advise updating it. We're really not going to be able to debug any problems on 10.3.2.
Comment 4 Francois Marier 2016-08-09 05:15:19 UTC
(In reply to Matt Turner from comment #3)
> Thanks for the info. To summarize: Sandybridge, modesetting driver,
> mesa-10.3.2.
> 
> I know Debian recently switched to using the modesetting driver by default,
> so if you have that I'm surprised that the version of Mesa you have is as
> old as it is. I would *strongly* advise updating it. We're really not going
> to be able to debug any problems on 10.3.2.

I just upgraded to mesa 11.2.2, I guess I'll file a new bug if it happens on that setup?
Comment 5 Matt Turner 2016-08-09 05:37:25 UTC
(In reply to Francois Marier from comment #4)
> (In reply to Matt Turner from comment #3)
> > Thanks for the info. To summarize: Sandybridge, modesetting driver,
> > mesa-10.3.2.
> > 
> > I know Debian recently switched to using the modesetting driver by default,
> > so if you have that I'm surprised that the version of Mesa you have is as
> > old as it is. I would *strongly* advise updating it. We're really not going
> > to be able to debug any problems on 10.3.2.
> 
> I just upgraded to mesa 11.2.2, I guess I'll file a new bug if it happens on
> that setup?

Please do. Thanks for going to the trouble to help make our software better :)

In the mean time, I'm going to mark this bug as WONTFIX since 10.3.x is long dead.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.