Bug 97265 - GPU hang while using opera on 4k display on linux 4.7
Summary: GPU hang while using opera on 4k display on linux 4.7
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-09 19:49 UTC by Tomáš Frýda
Modified: 2018-08-15 21:08 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Error logs including dmesg, /sys/class/drm/card0/error, kernel config and gentoo specific information such as installed packages and use flags (1.39 MB, application/x-xz)
2016-08-09 19:49 UTC, Tomáš Frýda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Frýda 2016-08-09 19:49:01 UTC
Created attachment 125651 [details]
Error logs including dmesg, /sys/class/drm/card0/error, kernel config and gentoo specific information such as installed packages and use flags

Occured during regular use of opera 39 on 4k display on laptop (DELL Inspiron 7548) with hybrid AMD GPU (m265) which is disabled (haven't even compiled drivers for it).

Maybe unrelated but sometimes some horizontal artifacts appear on dotted lines (such are used for example to notify user that some element is focused). These dotted lines are during this error merge into semi-solid line which overflows the element. But this happens only in same pixel row. Sometimes happens even outside of X on TTY1. But this behaviour is very unusual and as such I've been unable to trace the cause.


Desktop Environment: Gnome 3.18
Linux kernel: 4.7
x11-drivers/xf86-video-intel: 2.99.917-r2
media-libs/mesa: 11.0.6
Comment 1 Kenneth Graunke 2016-08-10 17:54:24 UTC
Please try upgrading Mesa.  11.0.x is no longer supported.
Comment 2 Illia Iorin 2018-06-26 15:36:05 UTC
I can't reproduce this bug when i using opera during 8 hours. I have these system parameters: 
    opera: 39 
    HD Graphics 620 (Kaby Lake GT2)
    gnome: 3.28.1
    mesa: 18.0.0
    Linux kernel: 4.15
    display resolution: 3840x2160
As I found in other bugs, 4k resolution matters (I have display with 3840x2160, but I know, that there are higher resolutions exist). If someone has possibility to test it on another 4k display, please try on it.
Comment 3 Dylan Baker 2018-08-15 21:08:30 UTC
I'm going to close this, it's for an ancient kernel and ancient mesa. Please re-open if you can reproduce with a more modern stack


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.