Bug 97286 - `make check` fails uniform-initializer-test
Summary: `make check` fails uniform-initializer-test
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Timothy Arceri
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-11 00:15 UTC by Mark Janes
Modified: 2016-08-11 16:37 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-08-11 00:15:42 UTC
Introduced in series ending with:

mesa 30e5ff706789823145c51313870c87bffab6943f
Author:     Timothy Arceri <timothy.arceri@collabora.com>
glsl: remove remaining tabs in link_uniform_initializers.cpp
Comment 1 Timothy Arceri 2016-08-11 00:36:52 UTC
Fix: https://patchwork.freedesktop.org/patch/104404/
Comment 2 Timothy Arceri 2016-08-11 02:20:11 UTC
By the way is it possible to get the make check failures included in the results from Jenkins? I don't seem to get them currently.
Comment 3 Timothy Arceri 2016-08-11 04:58:42 UTC
Fixed by:

author	Timothy Arceri <timothy.arceri@collabora.com>
commit	33b38157731bb4e9b79edeb4f66213c66813248f

glsl/tests: fix segfault in uniform initializer test

Caused by 549222f5

Tested-by: Aaron Watry <awatry@gmail.com>
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=97286
Comment 4 Mark Janes 2016-08-11 16:37:30 UTC
(In reply to Timothy Arceri from comment #2)
> By the way is it possible to get the make check failures included in the
> results from Jenkins? I don't seem to get them currently.

Thanks for the suggestion.

I agree that Intel's Mesa CI would be more valuable if it included build logs and gtest output.  I'll put that work item on the backlog for the automation.


bug/show.html.tmpl processed on Jan 18, 2017 at 04:10:45.
(provided by the Example extension).