Bug 97303 - battery mode for dpm state froze
Summary: battery mode for dpm state froze
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2016-08-11 17:36 UTC by f380cedric
Modified: 2019-11-19 09:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg log (46.07 KB, text/x-log)
2016-08-11 21:04 UTC, f380cedric
no flags Details
dsmeg output (83.93 KB, text/x-log)
2016-08-11 21:05 UTC, f380cedric
no flags Details
Dmesg battery dpm state on AC (94.50 KB, text/x-log)
2016-08-15 10:55 UTC, f380cedric
no flags Details
Dmesg battery dpm state on battery (97.98 KB, text/plain)
2016-08-15 11:01 UTC, f380cedric
no flags Details

Description f380cedric 2016-08-11 17:36:27 UTC
I try to use the dpm state, but when I set:

echo 'battery' > /sys/class/drm/card0/device/power_dpm_state

while on battery power, laptop freezes after a time.

I tried to add radeon.dpm=1 and (radeon.bapm=1 or radeon.bapm=0) but it does not fix. Originally, I discovered this issue using TLP (where you can find the ticket https://github.com/linrunner/TLP/issues/186).
Comment 1 Alex Deucher 2016-08-11 20:22:57 UTC
Please attach your xorg log and dmesg output.
Comment 2 f380cedric 2016-08-11 21:04:10 UTC
Created attachment 125717 [details]
Xorg log
Comment 3 f380cedric 2016-08-11 21:05:47 UTC
Created attachment 125718 [details]
dsmeg output

dsmeg when on performance mode and AC power
Comment 4 f380cedric 2016-08-15 10:55:03 UTC
Created attachment 125789 [details]
Dmesg battery dpm state on AC

Dmesg output in battery dpm state while on AC.
Comment 5 f380cedric 2016-08-15 11:01:22 UTC
Created attachment 125790 [details]
Dmesg battery dpm state on battery

I tried to catch the dmesg output right before pc freezing, I do not know if it is relevant. This is the latest dmesg output I caught (others were empty).
Comment 6 Martin Peres 2019-11-19 09:18:14 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/735.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.