Bug 97333 - Missing feature for remote desktop and virtual machine software: keyboard grabbing
Summary: Missing feature for remote desktop and virtual machine software: keyboard gra...
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: wayland (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
: 104051 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-13 16:20 UTC by Christian Stadelmann
Modified: 2017-12-04 07:40 UTC (History)
13 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Stadelmann 2016-08-13 16:20:39 UTC
One main difference between x11 and wayland is that in x11 all applications receive all input whereas in wayland the compositor receives input and decides which application may receive it. This causes a major issue with application which need to grab keyboard input for running or showing a nested desktop. This affects e.g. GUI virtual machines (SPICE clients), RDP clients, VNC clients, nested kwin/gnome-shell/whatever. Without giving these wayland clients the ability to grab input, they will not be able to handle keys which are also global key bindings in your wayland compositor, e.g. Alt+Tab or the Super key.

Games might also be affected, I don't know that for sure.

I'm posting this here to raise attention because
1. to fix this we need another protocol (extension)
2. this issue can't be fixed in a single application, it needs the whole stack (wayland library, compositors, affected applications) to change

IMHO, this is the biggest important feature that's still missing for wayland to be ready for production.

See also:
https://bugzilla.redhat.com/show_bug.cgi?id=1285770
https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/thread/BBPOOC4GVBJXHLKSSFLGERG6GYAU6M6U/
Comment 1 nick 2017-01-05 21:56:37 UTC
This is a major issue for users of assistive technology who rely on the keyboard to navigate within virtual machines.  Critical key bindings such as Alt+Tab, the Super key and so on are not supported.
Comment 2 Kamil Páral 2017-01-06 09:04:07 UTC
Yes. Please use the X11 session in such cases until this is fixed.
Comment 3 Michal Ambroz 2017-04-28 13:59:08 UTC
+1 ... having issues sending win alt-tab and other keys to VirtualBox, FreeRDP, vncviewer etc.
Comment 4 ringe 2017-11-29 11:17:03 UTC
Virtual Desktops makes it easy to switch hardware and take backups. Businesses often have Windows Terminal Servers for their applications.

Wayland preventing Alt+Tab and Alt+F4 inside VirtualBox VMs and Remmina connections makes Wayland unusable for the regular office users I manage.

It will be really nice when Wayland is usable for this purpose.
Comment 5 ringe 2017-11-29 11:30:25 UTC
Looks like this bug can be closed?
https://lists.freedesktop.org/archives/wayland-devel/2017-July/034459.html
Comment 6 Pekka Paalanen 2017-12-04 07:35:31 UTC
*** Bug 104051 has been marked as a duplicate of this bug. ***
Comment 7 Pekka Paalanen 2017-12-04 07:40:42 UTC
(In reply to ringe from comment #5)
> Looks like this bug can be closed?
> https://lists.freedesktop.org/archives/wayland-devel/2017-July/034459.html

Yes, I believe the issue is solved for Wayland.

What is remaining is independent feature requests for each compositor and related application to make use of the extension if they do not already.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.