Bug 9751 - i915_wait_irq crash on G965, 2.6.19.2
i915_wait_irq crash on G965, 2.6.19.2
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-23 20:33 UTC by Ryan Richter
Modified: 2009-08-17 12:27 UTC (History)
3 users (show)

See Also:


Attachments
Xorg configuration file (4.06 KB, text/plain)
2008-01-31 17:31 UTC, Mariano Boragno
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Richter 2007-01-23 20:33:58 UTC
Ever since upgrading an Intel G965 system from kernel 2.6.19 to 2.6.19.2 I've seen crashes preceded by these kernel messages:
[drm:i915_wait_irq] *ERROR* i915_wait_irq: EBUSY -- rec: 8029629 emitted: 8030262
[drm:i915_wait_irq] *ERROR* i915_wait_irq: EBUSY -- rec: 0 emitted: 2
Comment 1 rlc2 2007-12-15 18:29:52 UTC
A similar bug has been pasted to the Ubuntu forums:
https://lists.ubuntu.com/archives/kernel-bugs/2006-July/018652.html

I'm also seeing this issue on a Dell Inspiron 1420N running Ubuntu Gutsy, kernel is 2.6.22-14-generic.  lspci -v says this about the video:

VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA])
Comment 2 Mariano Boragno 2008-01-31 17:31:35 UTC
Created attachment 14063 [details]
Xorg configuration file
Comment 3 Mariano Boragno 2008-01-31 17:33:30 UTC
(In reply to comment #0)
> Ever since upgrading an Intel G965 system from kernel 2.6.19 to 2.6.19.2 I've
> seen crashes preceded by these kernel messages:
> [drm:i915_wait_irq] *ERROR* i915_wait_irq: EBUSY -- rec: 8029629 emitted:
> 8030262
> [drm:i915_wait_irq] *ERROR* i915_wait_irq: EBUSY -- rec: 0 emitted: 2
> 

I have exactly the same problem. I'm running a Mandriva 2008 one in a HP7010EG with intel chipset, details below. The X server hangs when running 3D applications like Flight Gear Flight Simulator, Blender, TORCS and some other. It seems to freeze only in windowed applications, not in fullscreen mode. When in fullscreen mode FGFS doesn't hangs. When it happens the screen turns black and start blinking slowly (every 1 or 2 seconds) as if the X server was trying to restart, but it never does. The mouse is visible during a while over the "blinking" cycle but the PC doesn't respond to any key, not even to the on/off button, I just have to force the power source to cut power pressing 4 second the OFF button.

Kernel:
2.6.22.9-laptop-1mdv
LSPCI:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
Kernel Log:
[drm:i915_wait_irq] *ERROR* i915_wait_irq: EBUSY -- rec: 1364822 emitted: 1364831

I've attached the xorg.conf file for refference.

Thanks.

SigmaOrion
Comment 4 Ian Romanick 2009-08-14 16:58:07 UTC
This is a really old bug.  Are you still able to reproduce this behavior on more recent kernels and Mesa?
Comment 5 Mariano Boragno 2009-08-17 11:05:15 UTC
(In reply to comment #4)
> This is a really old bug.  Are you still able to reproduce this behavior on
> more recent kernels and Mesa?
> 

I cannot reproduce this bug anymore =).

Regards...
Comment 6 Ian Romanick 2009-08-17 12:27:44 UTC
Closing.  If something similar comes up again, please submit a new bug.