Bug 97558 - [Broadwell] VGA projection system not detected as of Linux 4.7 (but fine before then)
Summary: [Broadwell] VGA projection system not detected as of Linux 4.7 (but fine befo...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-01 04:03 UTC by Andreas Kloeckner
Modified: 2017-07-24 22:40 UTC (History)
3 users (show)

See Also:
i915 platform: BDW
i915 features: display/Other


Attachments
Debian package info (versions etc) (54.02 KB, text/plain)
2016-09-01 12:07 UTC, Andreas Kloeckner
no flags Details
Dmesg log with drm.debug=0xe on 4.6 (124.76 KB, text/plain)
2016-09-10 00:12 UTC, Andreas Kloeckner
no flags Details
Dmesg log with drm.debug=0xe on 4.8 (122.39 KB, text/plain)
2016-09-10 00:12 UTC, Andreas Kloeckner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kloeckner 2016-09-01 04:03:19 UTC
Hi there,

as of Linux 4.7 (tried -rc7 and 4.7.2), my ThinkPad X250 (i7-500U) will no longer recognize the projection system in a large lecture hall at my work when plugged in through the VGA port (which is the only option). There is no display detected on the VGA port when I type "xrandr".

Using kernel 4.6 (and, as far as I can tell, all kernels before that), there is no issue. The display is detected and activated as expected.

Kernel 4.7 *will* properly detect and talk to a Dell LCD monitor through the VGA port, so the basic functionality is working.

I am using Debian with the "modesetting" DDX I believe.

More detailed info:
https://gist.github.com/inducer/12d4507f454c27319e5585629d9727a5

I would much appreciate any help you can provide.

Thanks!
Comment 1 Jani Nikula 2016-09-01 08:40:34 UTC
(In reply to Andreas Kloeckner from comment #0)
> More detailed info:
> https://gist.github.com/inducer/12d4507f454c27319e5585629d9727a5

Please keep all information in the bug.
Comment 2 Andreas Kloeckner 2016-09-01 12:07:11 UTC
Created attachment 126157 [details]
Debian package info (versions etc)
Comment 3 Andreas Kloeckner 2016-09-01 12:07:30 UTC
Uploaded Debian bug info from gist as attachment.
Comment 4 Andreas Kloeckner 2016-09-01 12:08:30 UTC
I should add that this happened not just with the projection system at the University of Illinois (my employer), but also at a conference at the University of Warwick in the UK this summer.
Comment 5 Ville Syrjala 2016-09-06 14:38:42 UTC
Can you attach full dmesg from the working and non-working setups, both with drm.debug=0xe passed to the kernel command line on boot.
Comment 6 Andreas Kloeckner 2016-09-10 00:12:13 UTC
Created attachment 126447 [details]
Dmesg log with drm.debug=0xe on 4.6
Comment 7 Andreas Kloeckner 2016-09-10 00:12:55 UTC
Created attachment 126448 [details]
Dmesg log with drm.debug=0xe on 4.8
Comment 8 Andreas Kloeckner 2016-09-10 00:13:30 UTC
Logs uploaded. The plug attempts are towards the end of the logs.
Comment 9 Andreas Kloeckner 2016-09-10 00:14:03 UTC
That kernel 4.8 is Debian's 4.8rc5, if it makes a difference.
Comment 10 Ville Syrjala 2016-09-20 14:01:21 UTC
Please test
git://github.com/vsyrjala/linux.git dp_connection_unknown
Comment 11 Andreas Kloeckner 2016-09-25 15:05:11 UTC
Thank you for looking into this!

I tried, but it turns out the only plausible way for me to build a kernel usable with my distribution (Debian) is as a patched distro kernel. I tried turning your patch into something I can apply on top of 4.8-rc5 (the current distro kernel), but I failed. Just using your two most recent commits don't apply cleanly, and the complete diff between 4.8-rc5 and your kernel doesn't apply cleanly to the distro kernel because of conflicts with distro patches. Any advice? Is there some way for you to extract only the i915-related changes? Thanks, and sorry for not responding sooner.
Comment 12 Ville Syrjala 2016-09-26 07:31:07 UTC
(In reply to Andreas Kloeckner from comment #11)
> Thank you for looking into this!
> 
> I tried, but it turns out the only plausible way for me to build a kernel
> usable with my distribution (Debian) is as a patched distro kernel.

I don't know what kind of crazy setup you have, but Debian itself definitely does not require any out of tree patches in the kernel.
Comment 13 Andrzej Pronobis 2016-09-30 02:34:39 UTC
I can confirm that adding the last 2 commits from the branch you listed on top of todays drm-intel-nightly solves the problem! When masking pin 15 of VGA (EDID i2c clock I think) I can still get up to 1024x768 detected with the commits, while the display is not detected at all without the commits. Unfortunately, many projectors still do not provide the i2c interface or the cables that are used simply do not provide all the pins.
Comment 14 Andrzej Pronobis 2016-10-17 00:15:58 UTC
Will these commits be merged to intel-drm-nightly?
Comment 15 Gwendal 2016-10-28 13:37:23 UTC
Hello,

I have the same problem (I think): beamers were working perfectly fine until a system update weeks ago.

My configuration:
- Fedora 25 beta (but the problem was there with F24 as well)
- 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
- linux 4.8.4-301.fc25.x86_64

Regular Iijama monitors work fine in VGA (both the one I have at home and the one from my office, which is a Prolite XB2485WSU).

However beamers (rather old, which is typical in universities) do not work in VGA: nothing detected with xrandr or anything else. I have this situation with two different beamers.

If I can provide more information, please do not hesitate to ask!

Thanks! Regards
Comment 16 Gwendal 2016-10-28 13:53:02 UTC
(In reply to Gwendal from comment #15)
> Hello,
> 
> I have the same problem (I think): beamers were working perfectly fine until
> a system update weeks ago.
> 
> My configuration:
> - Fedora 25 beta (but the problem was there with F24 as well)
> - 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT
> Integrated Graphics Controller (rev 0b)
> - linux 4.8.4-301.fc25.x86_64
> 
> Regular Iijama monitors work fine in VGA (both the one I have at home and
> the one from my office, which is a Prolite XB2485WSU).
> 
> However beamers (rather old, which is typical in universities) do not work
> in VGA: nothing detected with xrandr or anything else. I have this situation
> with two different beamers.
> 
> If I can provide more information, please do not hesitate to ask!
> 
> Thanks! Regards

I forgot to mention my CPU name:

- Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz

Also, a recent possibly related bug: https://bugs.launchpad.net/ubuntu/+source/linux-lts-xenial/+bug/1619677
Comment 17 Ville Syrjala 2016-10-28 14:10:55 UTC
commit 16c83fad79ca912b8b5bbdcb5272794a2be41262
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Mon Oct 3 10:55:16 2016 +0300

    drm/i915: Allow DP to work w/o EDID
Comment 18 Gwendal 2016-10-28 14:36:40 UTC
(In reply to Gwendal from comment #16)
> (In reply to Gwendal from comment #15)
> > Hello,
> > 
> > I have the same problem (I think): beamers were working perfectly fine until
> > a system update weeks ago.
> > 
> > My configuration:
> > - Fedora 25 beta (but the problem was there with F24 as well)
> > - 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT
> > Integrated Graphics Controller (rev 0b)
> > - linux 4.8.4-301.fc25.x86_64
> > 
> > Regular Iijama monitors work fine in VGA (both the one I have at home and
> > the one from my office, which is a Prolite XB2485WSU).
> > 
> > However beamers (rather old, which is typical in universities) do not work
> > in VGA: nothing detected with xrandr or anything else. I have this situation
> > with two different beamers.
> > 
> > If I can provide more information, please do not hesitate to ask!
> > 
> > Thanks! Regards
> 
> I forgot to mention my CPU name:
> 
> - Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
> 
> Also, a recent possibly related bug:
> https://bugs.launchpad.net/ubuntu/+source/linux-lts-xenial/+bug/1619677

OK, I've just tested on the same system with an older kernel 4.6.0, and it works again using VGA on the same old beamer that didn't work in 4.8.4.

On Fedora 25 beta I used koji to install 4.6:

$ wget https://kojipkgs.fedoraproject.org//packages/kernel/4.6.0/1.fc25/x86_64/kernel-4.6.0-1.fc25.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/kernel/4.6.0/1.fc25/x86_64/kernel-core-4.6.0-1.fc25.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/kernel/4.6.0/1.fc25/x86_64/kernel-modules-4.6.0-1.fc25.x86_64.rpm
$ sudo rpm -ivh --oldpackage ./kernel-4.6.0-1.fc25.x86_64.rpm ./kernel-core-4.6.0-1.fc25.x86_64.rpm ./kernel-modules-4.6.0-1.fc25.x86_64.rpm


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.