Bug 97599 - Logo image looks different in Evince compared to other viewers
Summary: Logo image looks different in Evince compared to other viewers
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-05 10:53 UTC by Tomasz Kuchta
Modified: 2018-08-21 10:37 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Kuchta 2016-09-05 10:53:44 UTC
= Transfering this bug from GNOME Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=770429 =

 - Copy Evince bugzilla comments here -

Tomasz Kuchta 2016-08-26 08:25:50 UTC
Created attachment 334209 [details]
test file

File 109865.pdf is displayed slightly different by Evince, compared to other viewers. The top-left logo is brighter, with horizontal lines going across it.
I have tested that on Ubuntu 15.10, with Evince 3.16.1.


The file is "109865.pdf", from Govdocs1 data set (http://digitalcorpora.org/corpora/govdocs)

The file can be found in the following archive: http://digitalcorpora.org/corp/files/govdocs1/zipfiles/109.zip

I would be grateful for confirming.

 backtrace
Comment 1 Germán Poo-Caamaño 2016-08-26 16:55:09 UTC
Created attachment 334232 [details]
Evince 3.21/Poppler 0.46.0 side by side with Acrobat Reader

This is a screenshot side by side of Evince and Acrobat Reader rendering the same document.

I do not see major difference.

Beware that Ubuntu 15.10 ships poppler 0.33. Poppler is the library used by Evince to render PDF. Since 0.33 there have been many bugs fixed.

Please, try with a newer version of poppler and let us know if you can reproduce it the issue then.
Comment 2 Jason Crain 2016-09-04 02:23:34 UTC
Created attachment 334738 [details]
from pdftocairo 0.47.0

I see some odd horizontal banding, but it's only visible on higher zoom levels.  Attached is the output from pdftocairo version 0.47.0, at 200x200 ppi.  Since this looks like a bug in poppler, please follow the instructions at https://wiki.gnome.org/Apps/Evince/PopplerBugs#poppler and open a bug for poppler's cairo backend.

 - Copy in any links to attachments here -

https://bugzilla.gnome.org/attachment.cgi?id=334209
Comment 1 GitLab Migration User 2018-08-21 10:37:53 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/298.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.