Bug 97614 - occasional screen distortions with nouveau under 4.8.0-rc4+
Summary: occasional screen distortions with nouveau under 4.8.0-rc4+
Status: REOPENED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-06 14:44 UTC by Elmar Stellnberger
Modified: 2017-02-16 17:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg excerpt 'grep nouveau' (29.29 KB, text/plain)
2016-09-06 14:45 UTC, Elmar Stellnberger
no flags Details
screenshot with a plain xfce4 desktop (527.50 KB, image/jpeg)
2016-09-06 14:46 UTC, Elmar Stellnberger
no flags Details
screenshot2 with xfce4 (486.00 KB, image/jpeg)
2016-09-06 14:47 UTC, Elmar Stellnberger
no flags Details
similar messages from nouveau - though without visible screen distortions (6.97 KB, text/plain)
2016-09-07 14:45 UTC, Elmar Stellnberger
no flags Details
dmesg before crash (475.50 KB, image/jpeg)
2016-09-09 11:50 UTC, Elmar Stellnberger
no flags Details
newer dmesg with 4.8-rc7+ (20.20 KB, text/plain)
2016-09-21 10:11 UTC, Elmar Stellnberger
no flags Details
current dmesg for 4.10.0-rc8+; no screen distortions - considered good (5.58 KB, text/plain)
2017-02-16 17:23 UTC, Elmar Stellnberger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar Stellnberger 2016-09-06 14:44:13 UTC
There are occasional screen distortions with nouveau and kernel 4.8.0-rc4+. Have a look at the dmesg as well as the screenshots.

known bad: 9ca581b50dab6103183396852cc08e440fcda18e (see attached dmesg)
also bad: 593ee4edc51d99fadda9f6ee... (no dmesg available)
supposed to be good: v4.8.0-rc4 (as by the tag of 3eab887a55424...)

  The problem is hard to test for as the screen distortions only become visible from time to time. Also, v4.8.0-rc4 has been tested with the plasma4 desktop while 4.8.0-rc4+ versions have been tested with xfce4 so I can not tell with 100% certainty that the problem did not exist before.
Comment 1 Elmar Stellnberger 2016-09-06 14:45:45 UTC
Created attachment 126245 [details]
dmesg excerpt 'grep nouveau'
Comment 2 Elmar Stellnberger 2016-09-06 14:46:42 UTC
Created attachment 126246 [details]
screenshot with a plain xfce4 desktop
Comment 3 Elmar Stellnberger 2016-09-06 14:47:31 UTC
Created attachment 126247 [details]
screenshot2 with xfce4
Comment 4 Elmar Stellnberger 2016-09-06 14:50:25 UTC
  Note that in the second picture there should be two different images: one for the iiyama X4071UHSU display and another one for the LVDS. What has happened is that parts of the LVDS displayed image have become visible on the HDMI monitor which is wrong (there is only one background image per monitor).
Comment 5 Elmar Stellnberger 2016-09-07 14:45:31 UTC
Created attachment 126283 [details]
similar messages from nouveau - though without visible screen distortions
Comment 6 Elmar Stellnberger 2016-09-09 11:50:04 UTC
Created attachment 126372 [details]
dmesg before crash

As it seems the same problems do also lead to more or less frequent crashes.
Comment 7 Elmar Stellnberger 2016-09-09 11:53:41 UTC
see also: https://bugzilla.kernel.org/show_bug.cgi?id=156261
Comment 8 Elmar Stellnberger 2016-09-13 19:03:02 UTC
  I have tested it back down to 4.8.0-rc2 and it showed that the problem does also exist with 4.8.0-rc2.
Comment 9 Elmar Stellnberger 2016-09-21 10:11:18 UTC
Created attachment 126697 [details]
newer dmesg with 4.8-rc7+

  The original page_not_present errors seem to have been resolved upstreams. Now there are other dmesgg in the log. The screen distortions seem to have improved but are not completely gone (linux commit 7d1e042314619115153a0f6f06e4552c09a50e13).
Comment 10 Elmar Stellnberger 2016-09-22 20:49:51 UTC
  While there are only occasional screen distortions with xfce KDE5 plasma seems to fully break by these issues: see also https://bugs.kde.org/show_bug.cgi?id=368275. Just tell me if you should need more information; - tested with 4.8.0-rc7+.
Comment 11 Elmar Stellnberger 2017-02-16 17:23:06 UTC
Created attachment 129678 [details]
current dmesg for 4.10.0-rc8+; no screen distortions - considered good

currently no such distortions with vanilla 4.10.0-rc8+; this has likely already been resolved with 4.9.0+.
Comment 12 Elmar Stellnberger 2017-02-16 17:41:18 UTC
not all screen distortions have gone; you can just not see any major distortions. Some screen content has just gotten warped on scrolling; another time I had some black spots above the font with thunderbird.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.