Bug 97639 - Intermittent flickering artifacts with AMD R7 260x
Summary: Intermittent flickering artifacts with AMD R7 260x
Status: RESOLVED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-08 13:39 UTC by nucrap
Modified: 2019-01-14 11:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
my Xorg.0.log (61.72 KB, text/plain)
2016-09-08 13:39 UTC, nucrap
no flags Details
dmesg (74.26 KB, text/plain)
2016-09-09 07:21 UTC, nucrap
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description nucrap 2016-09-08 13:39:36 UTC
Created attachment 126306 [details]
my Xorg.0.log

Hi, I am using an MSI R7 260x OC with the new amdgpu driver. Everything seems to run fine (I have yet to experience any crashes), however there constantly flicker some artifacts on my screen.
In the Xorg.0.log I have noticed many suspicious error messages similar to this:

AMDGPU(0): amdgpu_dri2_flip_event_handler: Pageflip completion event has impossible msc 100169 < target_msc 100170

Looking at the description in the source code, it fits the bug I experience:
> Check for too small vblank count of pageflip completion, taking wraparound
> into account. This usually means some defective kms pageflip completion,
> causing wrong (msc, ust) return values and possible visual corruption.

I saw there was a similar bug (bug#91540), but it has been marked as fixed some time ago.

My config:
Linux v4.7.2 (amdgpu, cik and powerplay enabled)
xf86-video-ati v7.7.0
mesa v12.0.1
xorg-drivers v1.17
xserver v1.17.4
KDE Plasma 5 (kwin)

If you need any further info please ask.
Comment 1 nucrap 2016-09-08 13:47:56 UTC
Forgot one info:
xf86-video-amdgpu v1.1.0 (glamor)
Comment 2 Michel Dänzer 2016-09-09 00:35:18 UTC
Please attach the corresponding dmesg output.
Comment 3 nucrap 2016-09-09 07:21:23 UTC
Created attachment 126362 [details]
dmesg
Comment 4 nucrap 2016-10-02 17:12:55 UTC
Any ideas? This is extremely annoying :/
Comment 5 Michel Dänzer 2016-10-03 02:15:34 UTC
https://cgit.freedesktop.org/~agd5f/linux/commit/?h=drm-next-4.9&id=325cbba19a32b172300fc87cd4da7c45c4f9e0ba (and the changes before / after that one) may help for this.
Comment 6 nucrap 2016-10-07 11:55:10 UTC
Thanks. In which version will this commit be included?
Comment 7 nucrap 2016-10-07 11:56:22 UTC
Ah I see, Linux v4.9 right?
Comment 8 Alex Deucher 2016-10-07 13:22:10 UTC
yes, 4.9.
Comment 9 nucrap 2016-10-10 11:41:34 UTC
Thanks, would you be so kind and compose me a patch with all commits that I need and that I can apply on top of the kernel v4.8 sources (which I am currently using)? So that I can test if the issue is fixed.
Comment 10 Michel Dänzer 2016-10-12 08:58:39 UTC
Can you just try the drm-next-4.9 tree? It's based on 4.8-rc8, so should be pretty stable in general.
Comment 11 Michel Dänzer 2016-10-12 09:35:01 UTC
Alternatively, you can generate a diff between 4.8-rc8 and current drm-next-4.9 with

 git diff v4.8-rc8..8036617e92e3fad49eef9bbe868b661c58249aff

and apply that to 4.8.
Comment 12 Michel Dänzer 2019-01-11 17:29:18 UTC
Is this still happening with current drivers?
Comment 13 nucrap 2019-01-12 18:13:55 UTC
Hi, I don't know I have since switched my graphics card long ago
Comment 14 Michel Dänzer 2019-01-14 11:14:14 UTC
Thanks for the follow-up. Resolving as WONTFIX, since we can't know if it's fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.