Bug 97691 - [SKL KBL BSW BDW BXT] kms_pipe_color / ctm-0 subtests are failing
Summary: [SKL KBL BSW BDW BXT] kms_pipe_color / ctm-0 subtests are failing
Status: CLOSED MOVED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Lionel Landwerlin
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-09 09:11 UTC by cprigent
Modified: 2017-07-24 22:40 UTC (History)
1 user (show)

See Also:
i915 platform: BDW, BSW/CHT, BXT, KBL, SKL
i915 features: display/color management


Attachments
SKL_ctm-0_output (30.38 KB, text/plain)
2016-09-09 09:11 UTC, cprigent
no flags Details
SKL_ctm-0_kern.log (660.21 KB, text/plain)
2016-09-09 09:11 UTC, cprigent
no flags Details
KBL_ctm-0_output (29.18 KB, text/plain)
2016-09-09 10:39 UTC, cprigent
no flags Details
kbl_kms_flip__basic-flip-vs-dpms_kern.log (340.91 KB, text/plain)
2016-09-09 10:40 UTC, cprigent
no flags Details
BSW_ctm-0_kern.log (574.80 KB, text/plain)
2016-09-09 10:54 UTC, cprigent
no flags Details
BSW_ctm-0_output (25.52 KB, text/plain)
2016-09-09 10:54 UTC, cprigent
no flags Details
klb_ctm-0_kern.log (537.19 KB, text/plain)
2016-09-09 10:55 UTC, cprigent
no flags Details
BDW_ctm-0_kern.log (579.02 KB, text/plain)
2016-09-15 13:54 UTC, cprigent
no flags Details
BDW_ctm-0_output (29.31 KB, text/plain)
2016-09-15 13:54 UTC, cprigent
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description cprigent 2016-09-09 09:11:16 UTC
Created attachment 126365 [details]
SKL_ctm-0_output

Platform: NUC6i3SYB
CPU: Intel(R) Core(TM) i3-6100U CPU @ 2.30GHZ (family 6, model 78, stepping 3)
Motherboard version: H81132-502
GPU: Intel® HD Graphics 520 - Intel Corporation Sky Lake Integrated Graphics (rev 07)
Memory: one 8GB card Kingston KVR21S15D8/8
SSD: Samsung 850 EVO M.2 120 Go

Software
Bios: SYSKLi35.86A.0045.2016.0527.1055 from https://downloadcenter.intel.com/downloads/eula/26097/BIOS-Update-SYSKLi35-86A-?httpDown=https%3A%2F%2Fdownloadmirror.intel.com%2F26097%2Feng%2FSY0045.bio
Linux distribution: Ubuntu 16.04 64 bits
Kernel: 4.8.0-rc5 5986f29 from http://cgit.freedesktop.org/drm-intel/
  commit 5986f290e25f42d3d5df390411cc43683deb1301
  Author: Jani Nikula <jani.nikula@intel.com>
  Date:   Thu Sep 8 12:12:10 2016 +0300
  drm-intel-nightly: 2016y-09m-08d-09h-11m-50s UTC integration manifest
libdrm-2.4.70-6 4462303 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-11.2.2 3a9f628from git://anongit.freedesktop.org/mesa/mesa
cairo 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xorg-server-1.18.0-546 deae9c7 from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel 2.99.917-701 205146b from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva-1.7.0-47 2ebf897 from git://git.freedesktop.org/git/vaapi/libva 
vaapi-intel-driver: 1.7.0-95 1817bee from git://git.freedesktop.org/git/vaapi/intel-driver
Intel-Gpu-Tools 1.16 6bd4208 from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git
DMC 1.26 from https://01.org/sites/default/files/downloads/intelr-graphics-linux/skldmcver126.tar_1.bz2
GUC 6.1 from https://01.org/sites/default/files/downloads/intelr-graphics-linux/sklgucver61.tar.bz2

External screens: HDMI: Ctl IP2152 and DP: LG 23MB35PYI

Steps:
------
1. Execute kms_pipe_clor subtests:
ctm-0-25-pipe0
ctm-0-5-pipe0
ctm-0-75-pipe0
ctm-0-25-pipe1
ctm-0-5-pipe1
ctm-0-75-pipe1
ctm-0-25-pipe2
ctm-0-5-pipe2
ctm-0-75-pipe2 

Actual results:
---------------
Tests are fail

Expected result:
-----------------
Tests are Pass
Comment 1 cprigent 2016-09-09 09:11:59 UTC
Created attachment 126366 [details]
SKL_ctm-0_kern.log
Comment 2 cprigent 2016-09-09 10:39:42 UTC
Created attachment 126367 [details]
KBL_ctm-0_output

Reproduced on KBL-U

Platform: KABY LAKE-U
Processor : Genuine Intel(R) CPU 0000 @ 1.80GHz (cpu family: 6, model: 142, stepping: 9)
MCP : KBL-U J0 2+3e
QDF : QL9J
PCH: PCH-LP C1
CRB : KABY LAKE U DDR3L RVP7
Rework: O-16

Software
BIOS: 45.1 3KBLSE2R1.R00.X045.P01.1606291634 from https://ubit-artifactory-ba.intel.com/artifactory/owr-repos/Submissions/ifwi/KBL_ORANGE_IFWI_2016_WW27_3_03_SR'17/
ME FW: 11.6.0.1065
EC FW: 1.24
KSC: 1.24
Kernel: 4.8.0-rc5 5986f29 from http://cgit.freedesktop.org/drm-intel/
  commit 5986f290e25f42d3d5df390411cc43683deb1301
  Author: Jani Nikula <jani.nikula@intel.com>
  Date:   Thu Sep 8 12:12:10 2016 +0300
  drm-intel-nightly: 2016y-09m-08d-09h-11m-50s UTC integration manifest
libdrm-2.4.70-6 4462303 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-11.2.2 3a9f628from git://anongit.freedesktop.org/mesa/mesa
cairo 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xorg-server-1.18.0-546 deae9c7 from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel 2.99.917-701 205146b from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva-1.7.0-47 2ebf897 from git://git.freedesktop.org/git/vaapi/libva 
vaapi-intel-driver: 1.7.0-95 1817bee from git://git.freedesktop.org/git/vaapi/intel-driver
Intel-Gpu-Tools 1.16 6bd4208 from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git
Comment 3 cprigent 2016-09-09 10:40:03 UTC
Created attachment 126368 [details]
kbl_kms_flip__basic-flip-vs-dpms_kern.log
Comment 4 Lionel Landwerlin 2016-09-09 10:48:06 UTC
Did you make a mistake when attaching kms_flip kernel.log (rather then kms_pipe_color)?
Comment 5 cprigent 2016-09-09 10:54:25 UTC
Created attachment 126369 [details]
BSW_ctm-0_kern.log

Hardware: Acer Desktop
Motherboard: Aspire XC-704
CPU: Intel(R) Pentium(R) CPU N3700 @ 1.60GHz (Family 6, Model 76, Stepping 3)
GPU:  Intel® HD Graphics - Intel Corporation Device 22b1 (rev 21)
Memory card: 1 card 4GB Hynix HMT451S6BFR8APB
HDD: Western Digital WDC WD10EZEX-21M (1TB)

Software:
Bios: R01-A2
Linux distribution: Ubuntu 16.04 64 bits
Kernel: 4.8.0-rc5 5986f29 from http://cgit.freedesktop.org/drm-intel/
  commit 5986f290e25f42d3d5df390411cc43683deb1301
  Author: Jani Nikula <jani.nikula@intel.com>
  Date:   Thu Sep 8 12:12:10 2016 +0300
  drm-intel-nightly: 2016y-09m-08d-09h-11m-50s UTC integration manifest
libdrm-2.4.70-6 4462303 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-11.2.2 3a9f628from git://anongit.freedesktop.org/mesa/mesa
cairo 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xorg-server-1.18.0-546 deae9c7 from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel 2.99.917-701 205146b from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva-1.7.0-47 2ebf897 from git://git.freedesktop.org/git/vaapi/libva 
vaapi-intel-driver: 1.7.0-95 1817bee from git://git.freedesktop.org/git/vaapi/intel-driver
Intel-Gpu-Tools 1.16 6bd4208 from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git
Comment 6 cprigent 2016-09-09 10:54:44 UTC
Created attachment 126370 [details]
BSW_ctm-0_output
Comment 7 cprigent 2016-09-09 10:55:50 UTC
Created attachment 126371 [details]
klb_ctm-0_kern.log
Comment 8 cprigent 2016-09-09 10:57:15 UTC
(In reply to Lionel Landwerlin from comment #4)
> Did you make a mistake when attaching kms_flip kernel.log (rather then
> kms_pipe_color)?

Thanks. I now uploaded the right file.
Comment 9 cprigent 2016-09-15 13:54:20 UTC
Created attachment 126555 [details]
BDW_ctm-0_kern.log

BDW logs attached

Platform: NUC5i7RYB
CPU: Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz (Family 6, Model 61, Stepping 4)
Motherboard version: H73774-102
GPU: Intel® Iris™ Graphics 6100 - Intel Corporation Broadwell-U Integrated Graphics (rev 09)
Memory: two 4GB card Kingston 99U5469-045.A00LF
SSD: INTEL SSDSC2KW24

Software
Bios: RYBDWi35.86A.0358.2016.0606.1423 from https://downloadcenter.intel.com/downloads/eula/26081/BIOS-Update-RYBDWi35-86A-?httpDown=https%3A%2F%2Fdownloadmirror.intel.com%2F26081%2Feng%2FRY0358.bio
Linux distribution: Ubuntu 16.04 64 bits
Kernel: 4.8.0-rc5 bef9c1f from http://cgit.freedesktop.org/drm-intel/
  commit bef9c1f4afe24cfff578d386bde349add65673eb
  Author: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
  Date:   Mon Sep 12 11:35:34 2016 +0300
  drm-intel-nightly: 2016y-09m-12d-08h-35m-02s UTC integration manifest
libdrm-2.4.70-12 2d00869 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-11.2.2 3a9f628 from git://anongit.freedesktop.org/mesa/mesa
cairo 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xorg-server-1.18.0-549 527c6ba from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel 2.99.917-703 15c5ff1 from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva-1.7.0-47 2ebf897 from git://git.freedesktop.org/git/vaapi/libva 
vaapi-intel-driver: 1.7.0-117 8c11f51 from git://git.freedesktop.org/git/vaapi/intel-driver
Intel-Gpu-Tools 1.16 f565b6c from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git
Comment 10 cprigent 2016-09-15 13:54:38 UTC
Created attachment 126556 [details]
BDW_ctm-0_output
Comment 11 yann 2016-09-20 07:10:34 UTC
Christophe, please re-test: patch for igt submitted here: https://lists.freedesktop.org/archives/intel-gfx/2016-September/106802.html
Comment 12 Humberto Israel Perez Rodriguez 2016-09-26 23:01:59 UTC
the following subtest fail with the following configuration :


	  
Software information
============================================
Kernel version                  : 4.8.0-rc8-nightly+ (0e34cb5b35f0)
Linux distribution              : Ubuntu 16.04.1 LTS
Architecture                    : 64-bit
DRM version                     : 2.4.70 (0659558)
Cairo version                   : 1.15.2 (db8a7f1)
Intel GPU Tools version         : intel-gpu-tools-1.16-22-g200237a
Bios revision                   : 5.6
Bios release date               : 06/06/2016

Hardware information
============================================
Platform                        : BSW
Motherboard type                : NUC5i3RYB Desktop
CPU family                      : Core i3
CPU information                 : Intel(R) Core(TM) i3-5010U CPU @ 2.10GHz
GPU Card                        : Intel Corporation Broadwell-U Integrated Graphics (rev 09) (prog-if 00 [VGA controller])
Memory ram                      : 8 GB
Maximum memory ram allowed      : 16 GB
CPU thread                      : 4
CPU core                        : 2
Socket                          : Socket BGA1168
Signature                       : Type 0, Family 6, Model 61, Stepping 4


subtest
============================================
igt@kms_pipe_color@ctm-green-to-red-pipe0
igt@kms_pipe_color@ctm-0-25-pipe2
igt@kms_pipe_color@ctm-0-5-pipe2
igt@kms_pipe_color@ctm-0-75-pipe1
igt@kms_pipe_color@ctm-blue-to-red-pipe1
igt@kms_pipe_color@ctm-green-to-red-pipe1
igt@kms_pipe_color@ctm-negative-pipe1
igt@kms_pipe_color@ctm-red-to-blue-pipe1
igt@kms_pipe_color@ctm-0-25-pipe0
igt@kms_pipe_color@ctm-0-5-pipe1
igt@kms_pipe_color@ctm-0-75-pipe0
igt@kms_pipe_color@ctm-blue-to-red-pipe0
igt@kms_pipe_color@ctm-0-25-pipe1
igt@kms_pipe_color@ctm-red-to-blue-pipe0
igt@kms_pipe_color@ctm-0-5-pipe0
igt@kms_pipe_color@ctm-0-75-pipe2
igt@kms_pipe_color@ctm-negative-pipe0
Comment 13 Lionel Landwerlin 2016-09-28 11:01:53 UTC
I posted a fix here : https://patchwork.freedesktop.org/series/12654/
This is a regression that was introduced following some refactoring.

I can't get anybody to review this patch and since I don't have the permission to just land it, we're a bit stuck here...
Comment 14 maria guadalupe 2016-11-24 21:47:11 UTC
Issue still present over BSW with the following config:

subtest
===========================================
igt@kms_pipe_color@ctm-0-25-pipe0
igt@kms_pipe_color@ctm-0-25-pipe1
igt@kms_pipe_color@ctm-0-5-pipe0
igt@kms_pipe_color@ctm-0-5-pipe1
igt@kms_pipe_color@ctm-0-75-pipe0
igt@kms_pipe_color@ctm-0-75-pipe1
igt@kms_pipe_color@ctm-blue-to-red-pipe0
igt@kms_pipe_color@ctm-blue-to-red-pipe1
igt@kms_pipe_color@ctm-green-to-red-pipe0
igt@kms_pipe_color@ctm-green-to-red-pipe1
igt@kms_pipe_color@ctm-negative-pipe0
igt@kms_pipe_color@ctm-negative-pipe1
igt@kms_pipe_color@ctm-red-to-blue-pipe0
igt@kms_pipe_color@ctm-red-to-blue-pipe1
igt@kms_pipe_color@degamma-pipe0
igt@kms_pipe_color@degamma-pipe1
igt@kms_pipe_color@gamma-pipe0
igt@kms_pipe_color@gamma-pipe1
igt@kms_pipe_color@legacy-gamma-pipe0
igt@kms_pipe_color@legacy-gamma-pipe1
igt@kms_pipe_color@legacy-gamma-reset-pipe0
igt@kms_pipe_color@legacy-gamma-reset-pipe1


 Software information
============================================
Kernel version                  : 4.9.0-rc6-nightly+
Linux distribution              : Ubuntu 16.04.1 LTS
Architecture                    : 64-bit
Gfx stack code                  : 2141224538
xf86-video-intel version        : 2.99.917
Xorg-Xserver version            : 1.18.4
DRM version                     : 2.4.73
Cairo version                   : 1.15.2
Intel GPU Tools version         : Tag [intel-gpu-tools-1.16-156-gcddf996] / Commit [cddf996]
Kernel driver in use            : i915
Bios revision                   : 0.33
Bios release date               : 08/12/2015
KSC revision                    : 0.16


 Hardware information
============================================
Platform                        : BSW
Motherboard model               : 10G9000NUS
Motherboard type                : BRASWELL Desktop
Motherboard manufacturer        : LENOVO
CPU family                      : Pentium
CPU information                 : Intel(R) Pentium(R) CPU  N3700  @ 1.60GHz
GPU Card                        : Intel Corporation Device 22b1 (rev 21) (prog-if 00 [VGA controller])
Memory ram                      : 8 GB
Maximum memory ram allowed      : 8 GB
CPU thread                      : 4
CPU core                        : 4
Hard drive capacity             : 476GiB (512GB)
Comment 15 cprigent 2016-12-02 12:16:11 UTC
BSW case seems different, I reported it here: bug 98971
kms_pipe_color is 100% Pass on APL, KBL, SKL and BDW

Tested with:
Kernel: 4.9.0-rc7 8f02d21 branch drm-tip from https://cgit.freedesktop.org/drm-tip
  commit 8f02d2103390e48e9e76c9e75d16dbb4396484c8
  Author: Jani Nikula <jani.nikula@intel.com>
  Date:   Mon Nov 28 14:38:48 2016 +0200
  drm-tip: 2016y-11m-28d-12h-38m-14s UTC integration manifest

libdrm-2.4.73-12 23d10b8 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-13.0.0 df1b0a5 from git://anongit.freedesktop.org/mesa/mesa
cairo 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xorg-server-1.19.0-4 2de37eb from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel 2.99.917-736 bde9460 from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva-1.7.2-44 598fb9e from git://git.freedesktop.org/git/vaapi/libva 
vaapi-intel-driver: 1.7.2-189 ce55d7e from git://git.freedesktop.org/git/vaapi/intel-driver
intel-gpu-tools-1.16-164 7797517 from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.