Bug 97696 - Huge cursor sizes
Summary: Huge cursor sizes
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.9 (xserver-1.17.4)
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
Depends on:
Reported: 2016-09-09 16:11 UTC by Mick Mueck
Modified: 2019-05-23 18:31 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Video of huge cursor (2.73 MB, video/quicktime)
2016-09-09 16:11 UTC, Mick Mueck
Actual cursors are much bigger than the screen recording (142.56 KB, image/jpeg)
2016-09-09 17:35 UTC, Mick Mueck
Actual cursors are much bigger than the screen recording (128.42 KB, image/jpeg)
2016-09-09 17:35 UTC, Mick Mueck
My monitor setup (1.99 MB, image/jpeg)
2016-10-20 17:37 UTC, Mick Mueck
Cursor size in my regular account is about 2.5 lines high. (3.87 MB, image/jpeg)
2016-10-20 17:39 UTC, Mick Mueck
Cursor size in a new, virgin account (2.06 MB, image/jpeg)
2016-10-20 17:39 UTC, Mick Mueck

Description Mick Mueck 2016-09-09 16:11:41 UTC
Created attachment 126380 [details]
Video of huge cursor

A long time ago (at least a couple years now) either an XQuartz or an OS X update started giving me huge sized cursors in pretty much every X11 application I use (I'm displaying all my X11 windows on the Mac via SSH). I could have sworn I filed a bug report on it and have been waiting for it to get fixed for ages (it's my #1 usability issue), but having looked just now I don't see any such report, other than perhaps the closed report:


It's really annoying - I work in applications editing text where the I-beam cursor is about 4 lines of text high and selecting text is problematic, the cursor being used while editing graphics covers enough of the nearby stuff to make the whole process frustrating. I'm not clear I agree with the reasons the macosforge ticket 2112 was closed (assuming it's the same issue as I'm reporting).

I have attached a video of a couple small windows showing the problem. Whenever you see the smallest arrow cursor, that's the cursor size normally displaying on the Mac.
Comment 1 Mick Mueck 2016-09-09 17:33:58 UTC
I just took another look at the video I posted and realized that when doing a QuickTime screen recording that the big cursors are curiously captured smaller than they appear in real life. I took a picture of the (paused) screen recording beside the actual window I was recording to show the difference. The bigger cursor is the uglier, more obstructing one that I see in real life, the smaller one is an artifact of some QuickTime screen recording anomaly i.e. the problem I'm describing is *far* worse than the video indicates. See photographs attached.
Comment 2 Mick Mueck 2016-09-09 17:35:08 UTC
Created attachment 126416 [details]
Actual cursors are much bigger than the screen recording
Comment 3 Mick Mueck 2016-09-09 17:35:26 UTC
Created attachment 126417 [details]
Actual cursors are much bigger than the screen recording
Comment 4 Jeremy Huddleston Sequoia 2016-09-18 23:06:16 UTC
Yeah, that does look quite annoying, but we don't really do anything with the cursors directly.  We simply allow the clients to configure the cursors and pass that data through.  Since this is the only report of such issue, I urge you to try creating a new user account on your system in order to try reproducing the issue.  I suspect a user configuration option (eg: toolkit preferences file) might be causing this.
Comment 5 Mick Mueck 2016-10-20 17:37:54 UTC
Created attachment 127432 [details]
My monitor setup

This is my current monitor setup. It's a mid-2102 MacBook Pro with 2 external monitors connected via the 2 ThunderBolt ports.
Comment 6 Mick Mueck 2016-10-20 17:39:06 UTC
Created attachment 127433 [details]
Cursor size in my regular account is about 2.5 lines high.
Comment 7 Mick Mueck 2016-10-20 17:39:48 UTC
Created attachment 127434 [details]
Cursor size in a new, virgin account
Comment 8 Mick Mueck 2016-10-20 17:49:14 UTC
Thanks for your response Jeremy. I (finally) did as you suggested and tried to reproduce this in a newly created virgin account. Annoyingly, the problem is still there, but only to a slightly lesser degree. I attached some pictures to highlight this. In my regular account you can see that the cursor size is about 3.5 lines high, and in the virgin account it's about 2.5 lines high (both are still awful to deal with). Like I mentioned in my initial post, years ago this wasn't the case and when it first appeared I filed a bug report (but apparently it's nowhere to be found) and I've been waiting for a fix ever since.

I realize nobody else has reported this so that doesn't bode well for anything getting done. And of course you not having any free time doesn't help either!
Comment 9 Mick Mueck 2017-03-08 19:08:38 UTC
I recently tried out NX, instead of SSH, to view my Cadence schematics on my MacBook Pro (the Cadence software is running on a remote linux box). I noticed the huge cursor sizes weren't happening at all - everything was great. Given the same version of XQuartz was in effect during the SSH/NX comparison I'm now thinking maybe this is more of an SSH problem than an XQuartz problem. I'm just too illiterate in all of this stuff to make any more of a suggestion than that - I just hope it helps in finding a fix for this.
Comment 10 GitLab Migration User 2019-05-23 18:31:14 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/768.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.