Bug 97758 - mkfontdir crash in 2.7.10_beta2
Summary: mkfontdir crash in 2.7.10_beta2
Status: RESOLVED DUPLICATE of bug 96905
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: development (betas, rcs, git)
Hardware: Other All
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-10 00:07 UTC by Douglas Fields
Modified: 2016-09-18 23:43 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Douglas Fields 2016-09-10 00:07:45 UTC
I can't run mkfontdir at all on my computer with 2.7.10_beta2. See transcript below. It happens in any directory (with or without X fonts).

I tried to upgrade to _rc1 to see if it fixed it, but unfortunately that wouldn't run (see #97757).

AdmiralA:~$ mkfontdir
=================================================================
==957==ERROR: AddressSanitizer: heap-buffer-overflow on address 0x60300000dcbf at pc 0x00010a1619d1 bp 0x7fff55acf950 sp 0x7fff55acf110
READ of size 1 at 0x60300000dcbf thread T0
^C
Comment 1 Jeremy Huddleston Sequoia 2016-09-18 22:49:53 UTC

*** This bug has been marked as a duplicate of bug 96905 ***
Comment 2 Douglas Fields 2016-09-18 23:19:38 UTC
Sorry about opening the same bug twice. I had forgotten I had done so earlier this summer.
Comment 3 Jeremy Huddleston Sequoia 2016-09-18 23:43:00 UTC
Bug numbers are cheap ;)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.