Bug 97781 - [HSW, BYT, IVB] es2-cts.gtf.gl2extensiontests.depth_texture_cube_map.depth_texture_cube_map
Summary: [HSW, BYT, IVB] es2-cts.gtf.gl2extensiontests.depth_texture_cube_map.depth_te...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 12.0
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Emil Velikov
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-12 22:33 UTC by Mark Janes
Modified: 2016-09-16 19:36 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-09-12 22:33:46 UTC
Bisected to:
49e84b8f18631b9460ade078f86d7567b80c332d
Author:     Emil Velikov <emil.l.velikov@gmail.com>
Revert "i965/miptree: Set logical_depth0 == 6 for cube maps"
This reverts commit 48e9ecc47f078cba3f56694e4583003681717410.
The commit regressed several piglit tests on SNB/ILK hardware.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=97567


/tmp/build_root/m64/bin/es/cts/glcts --deqp-case=ES2-CTS.gtf.GL2ExtensionTests.depth_texture_cube_map.depth_texture_cube_map
dEQP Core GL-CTS-2.0 (0x0052484b) starting..
  target implementation = 'intel-gbm'

Test case 'ES2-CTS.gtf.GL2ExtensionTests.depth_texture_cube_map.depth_texture_cube_map'..
#+ Rendering mismatch.
  Fail (Fail)

DONE!

Test run totals:
  Passed:        0/1 (0.00%)
  Failed:        1/1 (100.00%)
  Not supported: 0/1 (0.00%)
  Warnings:      0/1 (0.00%)
Comment 1 Mark Janes 2016-09-12 22:56:07 UTC
Also regressed by the same commit on ivb, hsw, bdw, kbl and skl:

    piglit.spec.arb_texture_cube_map.copyteximage cube samples=4
    piglit.spec.arb_texture_cube_map.copyteximage cube samples=2
    piglit.spec.arb_texture_cube_map.copyteximage cube samples=6
    piglit.spec.arb_texture_cube_map.copyteximage cube
    piglit.spec.arb_texture_cube_map.copyteximage cube samples=8


/tmp/build_root/m64/lib/piglit/bin/copyteximage CUBE -samples=2 -auto
Testing GL_TEXTURE_CUBE_MAP
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RED
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RG
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGB8
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGB16
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGB16F
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGB32F
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGBA8
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGBA16
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGBA16F
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_RGBA32F
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_COMPRESSED_RED
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_COMPRESSED_RG
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_COMPRESSED_RGB
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_COMPRESSED_RGBA
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_LUMINANCE
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_LUMINANCE_ALPHA
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_INTENSITY
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_DEPTH_COMPONENT
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_DEPTH_COMPONENT16
Probe color at (304,12)
  Expected: 47 47 47 255
  Observed: 77 77 77 255
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_DEPTH_COMPONENT24
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_DEPTH_COMPONENT32F
Probe color at (336,0)
  Expected: 47 47 47 255
  Observed: 0 0 0 255
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_DEPTH24_STENCIL8
Texture target = GL_TEXTURE_CUBE_MAP, Internal format = GL_DEPTH32F_STENCIL8
Comment 2 Mark Janes 2016-09-12 22:58:41 UTC
This bug requires a quick release of 12.0.3

Please provide a branch for CI testing before applying new release notes/checksums.
Comment 3 Emil Velikov 2016-09-13 10:45:39 UTC
Ack, looking into it. Few quick ideas:
 - reintroduce the commit for the post SNB/ILK hardware
 - track/address follow-on patch(es) which depend on the behaviour introduced with the reverted patch.
Comment 4 Mark Janes 2016-09-13 12:32:28 UTC
It might also be a good idea to warn mesa-announce that 12.0.2 suffers from intermittent GPU Hangs on a range of intel hardware.
Comment 5 Emil Velikov 2016-09-13 14:11:17 UTC
(In reply to Mark Janes from comment #4)
> It might also be a good idea to warn mesa-announce that 12.0.2 suffers from
> intermittent GPU Hangs on a range of intel hardware.

Was this meant to be in this report ? You haven't mentioned anything like the before, plus it I haven't noticed any GPU hangs on my BDW with 12.0.2.

That aside: Yes, if you know a specific use case that causes GPU hangs, giving it wider audience would be nice IMHO.
Comment 6 Mark Janes 2016-09-13 16:37:59 UTC
The GPU Hangs are intermittent.  I only confirmed them this morning before my last comment.

Unfortunately, several engineers intel.com addresses (including myself) failed to receive your 12.0.2 release notification, due to issues with our corporate email server.  For that reason, testing and feedback on your release was delayed until yesterday.
Comment 7 Emil Velikov 2016-09-13 17:19:58 UTC
(In reply to Mark Janes from comment #6)
> The GPU Hangs are intermittent.  I only confirmed them this morning before
> my last comment.
> 
Ack. In that case, I'd spare mesa-announce for the moment.

> Unfortunately, several engineers intel.com addresses (including myself)
> failed to receive your 12.0.2 release notification, due to issues with our
> corporate email server.  For that reason, testing and feedback on your
> release was delayed until yesterday.
Is there anything I can do to prevent this for the future ?

Ftr reverting the following commit resolves the problem here. Just waiting for a piglit run to check that it doesn't cause regressions.

commit e1073719bc19d27a710b103438af5769ee7af38f
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Wed Jul 20 08:24:15 2016 -0700

    i965/miptree: Stop multiplying cube depth by 6 in HiZ calculations
    
    intel_mipmap_tree::logical_depth0 is now in number of 2D slices so we no
    longer need to be multiplying by 6.
Comment 8 Mark Janes 2016-09-13 17:50:20 UTC
My bisection produces the same result:

i965/miptree: Stop multiplying cube depth by 6 in HiZ calculations
Comment 9 Mark Janes 2016-09-13 18:01:22 UTC
Emil,

At this point, the CI has caught several regressions in stable branches immediately after you announced the release publicly.

I recommend providing a branch that I can test on the CI before you push anything to stable.  I can provide feedback within 30 minutes for modern platforms, and 2 hours for slower/older systems, during normal working hours.  Please do not release Mesa without confirmation from me.

-Mark
Comment 10 Mark Janes 2016-09-13 19:42:49 UTC
I am seeing a 32bit baytrail failure on:
piglit.spec.glsl-1_30.execution.tex-miplevel-selection texture(bias) cubeshadow

It bisected to 
mesa: fix format conversion bug in get_tex_rgba_uncompressed()

This may be spuriously bisecting due to gpu hangs.
Comment 11 Emil Velikov 2016-09-14 11:24:23 UTC
(In reply to Mark Janes from comment #8)
> My bisection produces the same result:
> 
> i965/miptree: Stop multiplying cube depth by 6 in HiZ calculations
That's exactly the same as mine in comment#7. Thanks for the confirmation.

I've triple checked on SNB and BDW and revering the commit does not cause any piglit regressions.

As per your request in comment #9, please test the 12.0 - the revert has been pushed.
Comment 12 Emil Velikov 2016-09-14 11:42:03 UTC
(In reply to Mark Janes from comment #9)
> Emil,
> 
> At this point, the CI has caught several regressions in stable branches
> immediately after you announced the release publicly.
> 
> I recommend providing a branch that I can test on the CI before you push
> anything to stable.  I can provide feedback within 30 minutes for modern
> platforms, and 2 hours for slower/older systems, during normal working
> hours.  Please do not release Mesa without confirmation from me.
> 
Yes, I agree that I should have pushed the revert earlier and ping you. Will do form now on.

Then again, AFAICT there's been a single regression due to last minute patch(es) - one of the reasons why I mentioned multiple times that late nominations are ill-advised.

Everything else has had 48+ hours between the branch push/email and the release. In this period you/fellow coworkers and others are encouraged to test things. IIRC of those there's been 24h+ which covers a full working day anywhere around the world.

While I think it's great and I would love to have confirmation from you/others (and release after that) it's simply not feasible. As you pointed out earlier - the email filter can eat the email and/or other things beyond our control can happen.

That said - revert is in 12.0, please test.

If you can find other bogus patches in stable please CC me alongside the patch author.
Comment 13 Mark Janes 2016-09-14 17:16:40 UTC
Testing has completed on all supported platforms.  Mesa 71b47b9cfe50b32de10a4c0fd6a6ea77f0de3c7f has no regressions compared to the 12.0.1 release.

thanks for giving me the opportunity to verify it.

-Mark


bug/show.html.tmpl processed on Jan 17, 2017 at 08:54:12.
(provided by the Example extension).