Bug 97808 - "tgsi/scan: don't set interp flags for inputs only used by INTERP instructions" causes glitches in wine with gallium nine
Summary: "tgsi/scan: don't set interp flags for inputs only used by INTERP instruction...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-14 16:05 UTC by raffarti
Modified: 2016-09-27 09:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
LoL 32 bit - bush (radeonsi gallium nine) (348.19 KB, video/webm)
2016-09-14 16:38 UTC, raffarti
Details
LoL 32 bit - decoration + shadows (radeonsi gallium nine) (1.36 MB, video/webm)
2016-09-14 16:39 UTC, raffarti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raffarti 2016-09-14 16:05:40 UTC
Commit 524fd55d2d973f50a5d8bc2255684610f5faae32 "tgsi/scan: don't set interp flags for inputs only used by INTERP instructions" caused regression in gallium nine.

Observed glitches in:
    -terrain on WoW 32 bit wine, only with multisampling;
    -grass on LoL 32 bit wine;
    -terrain on LoL 32 bit wine, only with shadows.

The glitch looks like noise/corruption on texture surfaces.
Comment 1 Ilia Mirkin 2016-09-14 16:12:58 UTC
Any particular driver?
Comment 2 raffarti 2016-09-14 16:20:56 UTC
(In reply to Ilia Mirkin from comment #1)
> Any particular driver?

Gallium Nine on radeonsi
Comment 3 Christoph Haag 2016-09-14 16:32:56 UTC
Also artifacts in native csgo: https://www.youtube.com/watch?v=pMBz2grTAQg
Comment 4 raffarti 2016-09-14 16:38:23 UTC
Created attachment 126521 [details]
LoL 32 bit - bush (radeonsi gallium nine)
Comment 5 raffarti 2016-09-14 16:39:46 UTC
Created attachment 126522 [details]
LoL 32 bit - decoration + shadows (radeonsi gallium nine)
Comment 6 Marek Olšák 2016-09-27 09:55:20 UTC
I reverted the problematic patch:
https://cgit.freedesktop.org/mesa/mesa/commit/?id=f019255acf4e3dab40f9504390357cd7798dd3e0

Closing.


bug/show.html.tmpl processed on Jan 18, 2017 at 04:04:36.
(provided by the Example extension).