Bug 97976 - VCE regression BO to small for addr since winsys/amdgpu: enable buffer allocation from slabs
Summary: VCE regression BO to small for addr since winsys/amdgpu: enable buffer alloca...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-29 13:41 UTC by Andy Furniss
Modified: 2016-09-30 10:47 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
candidate fix (5.42 KB, patch)
2016-09-29 16:31 UTC, Nicolai Hähnle
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Furniss 2016-09-29 13:41:18 UTC
R9 285 tonga, git llvm, drm-next-4.9-wip.

Since Mesa commit -

commit ffa1c669ddb48c25bab3457b8b2bfcd255acc674
Author: Nicolai Hähnle <nicolai.haehnle@amd.com>
Date:   Wed Sep 7 10:50:59 2016 +0200

    winsys/amdgpu: enable buffer allocation from slabs

Using VCE encode fails (but not instantly) with 

[drm:amdgpu_vce_cs_reloc [amdgpu]] *ERROR* BO to small for addr 0x010005fe00 139 138

If you have gstreamer + vce you may be able to reproduce with -

gst-launch-1.0 -f ximagesrc use-damage=0 startx=0 starty=0 endx=1919 endy=1079 ! queue ! videoconvert ! video/x-raw,framerate=60/1,format=NV12  ! queue ! vaapih264enc ! video/x-h264,profile=baseline ! fakesink

Which will run forever, it takes a few seconds to trigger for me. It assumes your screen is 1080p so may need tweaking and I guess may luck out of triggering at smaller sizes.

Other tests not involving gstreamer/screen grabbing = avconv reading 1080p rawvid from tmpfs are also affected.
Comment 1 Alex Deucher 2016-09-29 13:48:56 UTC

*** This bug has been marked as a duplicate of bug 97969 ***
Comment 2 Alex Deucher 2016-09-29 13:50:17 UTC
Still probably a duplicate, but different winsys.
Comment 3 Nicolai Hähnle 2016-09-29 13:59:12 UTC
Thanks for the report, I can reproduce this and will investigate.
Comment 4 Nicolai Hähnle 2016-09-29 16:31:54 UTC
Created attachment 126880 [details] [review]
candidate fix

Should be fixed by the attached patch.
Comment 5 Andy Furniss 2016-09-29 16:58:14 UTC
(In reply to Nicolai Hähnle from comment #4)
> Created attachment 126880 [details] [review] [review]
> candidate fix
> 
> Should be fixed by the attached patch.

Yes, working OK with that.
Comment 6 Nicolai Hähnle 2016-09-30 10:47:24 UTC
Should be fixed in Mesa master as of commit 13cb41f666212ed50a7939a37a373b4431a84033. Please re-open if the problem persists.


bug/show.html.tmpl processed on Feb 25, 2017 at 20:35:16.
(provided by the Example extension).