Bug 98002 - Mud rendering bug in Portal 2
Summary: Mud rendering bug in Portal 2
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 12.0
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-01 05:45 UTC by Clément Guérin
Modified: 2017-01-25 05:00 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot (11.29 MB, image/png)
2016-10-01 05:45 UTC, Clément Guérin
Details
NVIDIA screenshot (1.86 MB, image/png)
2016-11-04 10:40 UTC, Samuel Iglesias Gonsálvez
Details
SNB screenshot (1.81 MB, image/png)
2016-11-04 10:42 UTC, Samuel Iglesias Gonsálvez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clément Guérin 2016-10-01 05:45:54 UTC
Created attachment 126930 [details]
Screenshot

Software:
- Linux 4.7.5
- mesa 12.0.2 / llvm 3.8.1
- mesa 1d466b9 / llvm 282838

R9 Fury

See the screenshot attached. All the golden reflective surface should be dark as shown here: https://youtu.be/A0K5EXfgJnk?t=1h19m52s

You can find an apitrace here. http://ge.tt/6mikBDf2
Comment 1 Nicolai Hähnle 2016-10-04 16:02:24 UTC
Thank you for the report. I can reproduce this and will investigate.
Comment 2 Clément Guérin 2016-10-05 05:40:19 UTC
Nice. I also noticed that the heroe's hands a completely black during the final boss scene. Should I open a separate issue?
Comment 3 Michel Dänzer 2016-10-05 06:20:21 UTC
(In reply to Clément Guérin from comment #2)
> Nice. I also noticed that the heroe's hands a completely black during the
> final boss scene. Should I open a separate issue?

Sounds like bug 96512.
Comment 4 Nicolai Hähnle 2016-10-05 09:47:28 UTC
Those black objects could well be bug 96512. We may have to revisit it somehow.

Meanwhile, the first incorrect rendering of the issue here happens @514365 with program 3332, vertex shader source @79150, fragment shader @79234. There's no shadow sampling involved, so it must be a different bug.
Comment 5 Nicolai Hähnle 2016-10-05 13:15:31 UTC
I still don't know what causes the surfaces to be too bright. However, the excessive brightness also appears with llvmpipe, so this bug doesn't seem specific to radeonsi. Reassigning to Mesa core.
Comment 6 Samuel Iglesias Gonsálvez 2016-11-04 10:40:36 UTC
Created attachment 127756 [details]
NVIDIA screenshot

I can reproduce this issue with both Intel Sandybridge (Mesa master HEAD f009c98) and a dedicated NVIDIA NVS 4200M/PCIe/SSE2 gpu with the proprietary driver (4.4.0 NVIDIA 375.10). See attached pictures.
Comment 7 Samuel Iglesias Gonsálvez 2016-11-04 10:42:10 UTC
Created attachment 127757 [details]
SNB screenshot

This is the SNB's screenshot. I wonder if the problem is actually in Mesa, in both Mesa and NVIDIA or in the game itself. Can someone test in under AMD driver?
Comment 8 Samuel Iglesias Gonsálvez 2016-11-04 10:44:02 UTC
(In reply to Samuel Iglesias from comment #7)
> Created attachment 127757 [details]
> SNB screenshot
> 
> This is the SNB's screenshot. I wonder if the problem is actually in Mesa,
> in both Mesa and NVIDIA or in the game itself. Can someone test in under AMD
> driver?

I meant AMD proprietary driver.
Comment 9 almos 2016-11-04 11:17:37 UTC
I might be able to test this on the proprietary AMD driver, but I can't download the trace. I click on download, and nothing happens.
Comment 10 Clément Guérin 2016-11-05 23:02:26 UTC
almos, disabling your ad blocker should do the trick. Sorry about that.
Comment 11 almos 2016-11-05 23:51:19 UTC
(In reply to Clément Guérin from comment #10)
> almos, disabling your ad blocker should do the trick. Sorry about that.

I tried that, but apart from the very NSFW advertisements nothing happens.
Comment 12 Clément Guérin 2016-11-06 06:28:33 UTC
For some reason it doesn't work either with Firefox here, but it's fine with Epiphany (GNOME Web).
Comment 13 almos 2016-11-07 11:33:16 UTC
Ok, I managed to download the trace with Konqueror. I haven't tried it with fglrx yet, but I compared the attached screenshot with the YouTube video, and here are my thoughts.

Actually, the mud is rendered correctly, the problem is with the rocky walls of the cavern. It looks like the lighting is fullbright, and the fog is missing. I also read the shader in qapitrace, and I have no idea how it was supposed to add fog (I'm not an expert on GLSL though).

If you look at the middle of the attached screenshot, you can see some little black objects in the background. Those are also missing fog.

It seems this bug has been reported to Valve as https://github.com/ValveSoftware/steam-for-linux/issues/4414 , and it's not specific to Mesa.
Comment 14 Michel Dänzer 2016-11-08 01:11:48 UTC
Looks like a game bug.
Comment 15 Clément Guérin 2017-01-25 05:00:39 UTC
Today's Portal 2 update fixed the bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.