Bug 98128 - nir/tests/control_flow_tests.cpp:79:73: error: ‘nir_loop_first_cf_node’ was not declared in this scope
Summary: nir/tests/control_flow_tests.cpp:79:73: error: ‘nir_loop_first_cf_node’ was n...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2016-10-06 21:42 UTC by Vinson Lee
Modified: 2016-10-06 22:49 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2016-10-06 21:42:53 UTC
mesa: f96945c5b5c3a52685e76795f03f75c75fb62fc7 (master 12.1.0-devel)

  CXX      nir/tests/nir_tests_control_flow_tests-control_flow_tests.o
nir/tests/control_flow_tests.cpp: In member function ‘virtual void nir_cf_test_delete_break_in_loop_Test::TestBody()’:
nir/tests/control_flow_tests.cpp:79:73: error: ‘nir_loop_first_cf_node’ was not declared in this scope
    nir_block *block_1 = nir_cf_node_as_block(nir_loop_first_cf_node(loop));
                                                                         ^

2ed17d46de045404042f13c6591895a1cf31b167 is the first bad commit
commit 2ed17d46de045404042f13c6591895a1cf31b167
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Wed Oct 5 19:08:57 2016 -0700

    nir: Make nir_foo_first/last_cf_node return a block instead
    
    One of NIR's invariants is that control flow lists always start and end
    with blocks.  There's no good reason why we should return a cf_node from
    these functions since we know that it's always a block.  Making it a block
    lets us remove a bunch of code.
    
    Signed-off-by: Jason Ekstrand <jason@jlekstrand.net>
    Reviewed-by: Connor Abbott <cwabbott0@gmail.com>

:040000 040000 0ecfd382f1e2c6fafb103838f5da4f711b8eeebd 1ed04a96ce72361430d8e7fbfcf62557745a5ecf M	src
bisect run success
Comment 1 Jason Ekstrand 2016-10-06 22:49:08 UTC
Sorry about that.  It's fixed now:

commit 325b3fd668369e2ed0af937843e80e750d0b91ed
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Thu Oct 6 15:46:22 2016 -0700

    nir: Fix the control flow tests for nir_loop_first_block changes
    
    Commit 2ed17d46de045404042f13c6591895a1cf31b167 changed
    nir_loop_first_cf_node and friends to return a nir_block instead of a
    nir_cf_node.  This broke one of the NIR control flow tests.
    
    Signed-off-by: Jason Ekstrand <jason@jlekstrand.net>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=98128


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.