Bug 98138 - Random Freeze - nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Summary: Random Freeze - nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Status: RESOLVED DUPLICATE of bug 100567
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-07 05:16 UTC by Stefan Kelemen
Modified: 2019-01-05 21:44 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Kelemen 2016-10-07 05:16:03 UTC
Since im Using KDE Plasma, i have the Problem the system is Freezing randomly over the when the Desktop is locked

kern.log when the problem begins

Oct  5 02:28:06 druuhl kernel: [73499.905933] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct  5 02:28:06 druuhl kernel: [73499.905939] nouveau 0000:01:00.0: fifo: sw engine fault on channel 5, recovering...
Oct  5 02:28:08 druuhl kernel: [73501.905656] nouveau 0000:01:00.0: fifo: runlist 0 update timeout
Oct  5 02:28:10 druuhl kernel: [73504.200746] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct  5 02:28:15 druuhl kernel: [73508.495393] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct  5 02:28:19 druuhl kernel: [73512.790100] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct  5 02:28:23 druuhl kernel: [73517.084810] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]
Oct  5 02:28:27 druuhl kernel: [73521.379625] nouveau 0000:01:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]

when the Desktop is unlocked over night there is no freeze. Some Discussion about this describe problems with Fullscreen Application like Libreoffice, this would match with my research.

Im Using Neptune Linux - Debian with KDE Plasma and i have the Problem with Kernel 4.4.13 to 4.4.20.

Linux druuhl 4.4.20 #8 SMP PREEMPT Thu Sep 8 10:25:38 CEST 2016 x86_64 GNU/Linux
kdeplasma 5.6 to 5.8
xserver-xorg-video-nouveau 1.0.12
xorg 7.7
Comment 1 Stefan Kelemen 2017-01-10 07:41:55 UTC
Resolved by NeptuneOS with new build grafikstack
Comment 2 kenorb 2019-01-05 21:43:37 UTC
Related: #100567
Comment 3 kenorb 2019-01-05 21:44:24 UTC

*** This bug has been marked as a duplicate of bug 100567 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.