Bug 98176 - External HDMI monitor not woken from sleep/power saving mode when coming back from idle
Summary: External HDMI monitor not woken from sleep/power saving mode when coming back...
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 12.0
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-09 19:58 UTC by Jean-François Fortin Tam
Modified: 2016-10-10 00:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2016-10-09 19:58:54 UTC
I have a LG 25UM58-P 2560x1080 monitor, which only has two HDMI inputs, connected to my Radeon 7770's HDMI port. It works fine, except that whenever the computer/radeon puts the monitor to sleep (when I lock my screen or put the computer into suspend mode), the screen monitor loses the signal and turns off entirely, requiring me to force-turn-it-on whenever I reactivate my computer and unlock my screen.

This did not happen with my previous monitor connected over DVI, and I thought "oh well, maybe it's a quirk of the new monitor"... except that while testing out a nVidia FX 580 with the Nouveau driver today, I realized that this driver was able to wake up the screen from GNOME Shell's screen lock, so that indicates that leads me to believe the radeonsi driver actually is the one causing the problem.
Comment 1 Jean-François Fortin Tam 2016-10-10 00:58:30 UTC
Actually no, I am mistaken... I didn't look closely enough: the nvidia card just doesn't truly blank the screen, so the monitor does not go into power save mode. An intel GPU had the same behavior as the radeonsi, so the monitor is really the cause of the problem, probably not radeonsi.


bug/show.html.tmpl processed on Mar 25, 2017 at 23:29:29.
(provided by the Example extension).