Bug 98264 - Build broken for i965 due to multiple deifnitions of intelFenceExtension
Summary: Build broken for i965 due to multiple deifnitions of intelFenceExtension
Status: CLOSED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: All All
: medium critical
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 98262 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-14 18:09 UTC by Dylan Baker
Modified: 2016-10-14 18:44 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dylan Baker 2016-10-14 18:09:46 UTC
Author:     Mauro Rossi <issor.oruam@gmail.com>                                                          
AuthorDate: Thu Jul 14 05:33:16 2016 +0200                                                               
Commit:     Emil Velikov <emil.l.velikov@gmail.com>                                                      
CommitDate: Fri Oct 14 15:43:53 2016 +0100                                                               

    i915/sync: Implement DRI2_Fence extension

    Here is the porting of corresponding patch for i965,
    i.e. commit c636284 i965/sync: Implement DRI2_Fence extension

    Here follows part of original commit message by Chad Versace:

    "This enables EGL_KHR_fence_sync and EGL_KHR_wait_sync."


11:04:59 i965/.libs/libi965_dri.a(brw_sync.o):(.data.rel.ro.local+0x0): multiple definition of `intelFenceExtension'
11:04:59 i915/.libs/libi915_dri.a(intel_syncobj.o):(.data.rel.ro.local+0x0): first defined here
11:04:59 collect2: error: ld returned 1 exit status
11:04:59 Makefile:695: recipe for target 'mesa_dri_drivers.la' failed
Comment 1 Dylan Baker 2016-10-14 18:22:55 UTC
only when building with i915 and i965
Comment 2 Emil Velikov 2016-10-14 18:35:25 UTC
Fixed with commit 7cb197c3a8ca44fc359ce69ff72ef68d85f7b181.

I should have built both drivers at the same time, even though it was a i915 only change.
Comment 3 Emil Velikov 2016-10-14 18:36:27 UTC
*** Bug 98262 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.